Go920 - QUICK GPS FIX An important update is available .....


Joined
Jan 24, 2008
Messages
34
Location
Ammanford, Wales
TomTom Model(s)
GO920
Currently travelling in the US and received an email advising of the above.

So took a backup before starting, then downloaded the important update.

Result was that the GO 920 will no longer boot up. It got to the screen asking for an OKay then just boots again to the same screen. Tried to restore the data back and no joy same result.

Removed the SD card and tried to scam it for error .... none found.
Tried booting from the internal memory and it eventually did so. But with my older maps. In doing so I've lost my lane features and the road speed signs.

Tried getting it to boot from the SD card and now it does, but with no lane features or speed limits shown and it would appear that I've lost my purchased [in 2015] maps.

So I've spent hours of my vacation trying to sort this out. What a crap update! TomTom should be ashamed of themselves releasing rubbish like this. In addition, the fix doesn't even work any quicker!!!! Satellites still take forever to be found.

So I am quite unhappy. How can I retrieve my purchased maps?

Any ideas?
 
Ad

Advertisements

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,181
Location
Toronto Canada
TomTom Model(s)
1535 LIVE; Via 1605; Go 50; Go 520
Are you travelling with the computer that you used back home to purchase the map? If so, connect to Home, Manage my Device, items on device, maps, what shows there?

Items on computer, maps, what shows there?

When you say you made a backup, was it using Home (hope not) or doing a manual backup of both the internal contents and one for the contents of the sdhc card?
 
Joined
Jan 24, 2008
Messages
34
Location
Ammanford, Wales
TomTom Model(s)
GO920
No longer have the PC that I had when we purchased the maps.
Regrettably, used Home to take a backup.
 
Last edited:
Joined
Jan 24, 2008
Messages
34
Location
Ammanford, Wales
TomTom Model(s)
GO920
Connect to Home, Manage my Device, items on device, maps. On the internal it has maps 710.1576. On the memory card I have maps 940.5693.

But for whatever reason, the screen shows that I am using only the older map is being read. How can I get the device to read the later maps and how me Show Lane Image once more?
 
Last edited:

canderson

Moderator
Joined
Dec 28, 2007
Messages
11,355
Location
Colorado, USA
TomTom Model(s)
GO720, GO740TM Live, GO 1535 Live, Via 1535, Via 1605, GO 52, GO 600, GO 620, GO 630, TomTom Bridge
Hmmm... I wonder if this is what another user reported as "An important update..." for his 700?

@elton
Do you know how to view the header information on an email that you have received? If so, can you copy and post that information here, please?

@dhn
Are you aware from the TomTom board if there are thoughts that some errant version of a GPSFix is out there that might be causing issues and needs to be replaced?
 
Joined
Jan 24, 2008
Messages
34
Location
Ammanford, Wales
TomTom Model(s)
GO920
Not 100% sure how to read the header. Would I be correct in saying it's to 'Show Original' ? Like this:

Delivered-To: (e-mail address removed)
Received: by 10.107.153.19 with SMTP id b19csp588254ioe;
Fri, 10 Jun 2016 22:01:05 -0700 (PDT)
X-Received: by 10.98.51.197 with SMTP id z188mr6419134pfz.100.1465621259614;
Fri, 10 Jun 2016 22:00:59 -0700 (PDT)
Return-Path: <[email protected]>
Received: from omp.email.tomtommailer.com (omp.email.tomtommailer.com. [199.7.202.129])
by mx.google.com with ESMTPS id bh4si2572154pab.146.2016.06.10.22.00.59
for <[email protected]>
(version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
Fri, 10 Jun 2016 22:00:59 -0700 (PDT)
Received-SPF: pass (google.com: domain of (e-mail address removed) designates 199.7.202.129 as permitted sender) client-ip=199.7.202.129;
Authentication-Results: mx.google.com;
dkim=pass [email protected];
dkim=pass [email protected];
spf=pass (google.com: domain of (e-mail address removed) designates 199.7.202.129 as permitted sender) [email protected];
dmarc=pass (p=REJECT dis=NONE) header.from=email.tomtommailer.com
DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; s=tomtommailer; d=email.tomtommailer.com;
h=MIME-Version:Content-Type:Date:To:From:Reply-To:Subject:Feedback-ID:Message-ID; [email protected];
bh=Wi+gY+EcE/BckPkcDw5rEauHJbI=;
b=MXagemFrcR/xFOi2hBwgLsjuCZnpSDMa5R/oScUYCqMuqat0FoxtkDV3ECJSKFdpFBzdha3q7B3e
/S3ygE7k+KN62jd1nql4SEAu0CDoPNZnxPxtRZBssU5Z7WptgkBtP7EDkJym5RelMwEcCe9I/TjF
0zd8HQ/GiZoA4yY6urQ=
DKIM-Signature: v=1; a=rsa-sha1; c=relaxed/relaxed; s=oraclersys; d=responsys.net;
h=MIME-Version:Content-Type:Date:To:From:Reply-To:Subject:Feedback-ID:Message-ID;
bh=Wi+gY+EcE/BckPkcDw5rEauHJbI=;
b=wsAErLIknu43KGcL5+0t7I+rLFXtirNFRv+5lyE86lnueIDMz4uxRU0Mov1j0YNM/1XB+tJtky1I
YJ9+v7LQhuqzePU/pNziNxglTxiuZwoiz+B+nSB379dCZR+cULfvFlUzvjAutUpN6gjC9zxLoq13
HZzuqsHeqUYS7WGUptE=
 
Ad

Advertisements

Joined
Jan 24, 2008
Messages
34
Location
Ammanford, Wales
TomTom Model(s)
GO920
Had another play this morning ...... using HOME, I selected the maps on the SD card. The lane features are now there and all my previous FAVS too ..... but when I disconnect the device from the PC, the unit boots upto the Legal Notice screen and freezes ..... pressing the 'I agree' button does nothing .... leaving the unit for 20 seconds and it reboots to the same screen again!

Ideas?
 

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,181
Location
Toronto Canada
TomTom Model(s)
1535 LIVE; Via 1605; Go 50; Go 520
Can you connect to Home and run the emulator (Run my device on second screen)?

If so, edit a favourite by adding one, deleting one or editing one, it doesn't matter. Save and disconnect properly from Home using the device disconnect icon.

See if it boots properly then.

If not, try this:

Connect to the computer and run the ClearFlash tool 3 times (get it here: http://us.support.tomtom.com/app/answers/detail/a_id/6211/kw/clear flash tool). You won't get much user feedback. Just run it 3 times.

See if that helps.
 

canderson

Moderator
Joined
Dec 28, 2007
Messages
11,355
Location
Colorado, USA
TomTom Model(s)
GO720, GO740TM Live, GO 1535 Live, Via 1535, Via 1605, GO 52, GO 600, GO 620, GO 630, TomTom Bridge
Many thanks, Elton. That was perfect. Just confirming that there wasn't something amiss -- the email is legit. It's so peculiar in its nature that I just wanted to confirm.

A whois returns the following, so I think I'll still follow up on this just to understand it better. A whois returns the following. I did not know that TomTom was using a U.S. system for this kind of email, but at least the operation sending (Responsys) is legit and in the business of contracting bulk emails like this.


NetRange: 199.7.200.0 - 199.7.207.255
CIDR: 199.7.200.0/21
NetName: RESPONSYS-NETOPS
NetHandle: NET-199-7-200-0-1
Parent: NET199 (NET-199-0-0-0-0)
NetType: Direct Assignment
OriginAS: AS16474, AS15334
Organization: Responsys Inc. (RSYS)
RegDate: 2010-06-15
Updated: 2012-08-15
Ref: https://whois.arin.net/rest/net/NET-199-7-200-0-1


OrgName: Responsys Inc.
OrgId: RSYS
Address: 1100 Grundy Lane,
Address: Suite 300
City: San Bruno
StateProv: CA
PostalCode: 94066
Country: US
RegDate: 1999-05-21
Updated: 2012-09-27
Ref: https://whois.arin.net/rest/org/RSYS
 
Joined
Jan 24, 2008
Messages
34
Location
Ammanford, Wales
TomTom Model(s)
GO920
Okay. Thanks for the replies.
Earlier today I connected to HOME and selected my SD card. I applied updates for the application twice.
The system when connected via HOME show me the correct maps. But as before, once I disconnect, it freezes on the Legal Notice screen.
So I connected, and deleted 3 Favourites.
Disconnected properly and started it back up.
Froze on the Legal Notice screen.

Downloaded the ClearFlash Tool. Installed it and ran 3 times.
Restarted but still a freeze at the Legal Notice screen.

Wonder if I deleted everything off the device bar the maps. Then reinstalled. Might that do something?
 

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,181
Location
Toronto Canada
TomTom Model(s)
1535 LIVE; Via 1605; Go 50; Go 520
Ad

Advertisements

Joined
Jan 24, 2008
Messages
34
Location
Ammanford, Wales
TomTom Model(s)
GO920
I was thinking along similar lines earlier; I was also thinking about dropping it in the bath!!!!!

So I am currently backing up as described in the link provided. It's likely to take a while ..... so I shall report back later.

Thank you very much for your continued assistence.
 
Joined
Jan 24, 2008
Messages
34
Location
Ammanford, Wales
TomTom Model(s)
GO920
Okay, followed that, re-formatted, not a quick format, copied everything back and switched on.
First it asks me to choose a map. Guam or US & Canada.
Choose US and Canada then comes the Legal Notice and freezes.
Connected via HOME .... all is good, Legal Notice is accepted. Deleted several favourites and all seems good.
Remove from PC and it freezes again!

Very, very frustrating!
 

canderson

Moderator
Joined
Dec 28, 2007
Messages
11,355
Location
Colorado, USA
TomTom Model(s)
GO720, GO740TM Live, GO 1535 Live, Via 1535, Via 1605, GO 52, GO 600, GO 620, GO 630, TomTom Bridge
Now use a paper clip or some other similarly pointy object to gently press the reset button in the hole on the bottom of the unit for a few seconds. Any difference?
 
Joined
Jan 24, 2008
Messages
34
Location
Ammanford, Wales
TomTom Model(s)
GO920
Tried the reset button .... no difference. when the unit starts it still freezes at the Legal Notice.
Daft thing is that it works perfectly through HOME .... frustrating as hell!!!
 

canderson

Moderator
Joined
Dec 28, 2007
Messages
11,355
Location
Colorado, USA
TomTom Model(s)
GO720, GO740TM Live, GO 1535 Live, Via 1535, Via 1605, GO 52, GO 600, GO 620, GO 630, TomTom Bridge
Go into your map folders and locate the mapsettings.cfg files in each. A typical 920 will have both European and N American maps, so there should be two of them. Find safe places on your PC to copy these files.

Once you've got your copies, DELETE those two files from your 920. Give it another go after that.
 
Ad

Advertisements

Joined
Jan 24, 2008
Messages
34
Location
Ammanford, Wales
TomTom Model(s)
GO920
Done that. Tried unit ...no change.
Tried HOME .... all favourites have now gone and unable to create new ones.
Disconnected from HOME and no change again. :(
 
Ad

Advertisements

Joined
Jan 24, 2008
Messages
34
Location
Ammanford, Wales
TomTom Model(s)
GO920
Well, wasted a lot of time trying to sort this out while on holiday, and a lot of time trying to navigate around the Boston area trying to find places that the SatNav should have taken me too. So I've taken the plunge and bought a Garmin replacement. Wasn't something I'd planned to do .... but want to enjoy whats left of my vacation without struggling further. It took an hour to update the latest maps and is good to go. Didn't plan on spending $160 on something I already had ..... but needs insisted.

So thanks TomTom for bricking my GO920 with an important update. I shall try and take this further with TomTom when I return home in 2 weeks time.

Thanks to all the contributers for providing solutions to try. Appreciate it guys.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top