GO720 Internal Memory FATAL Write Error - bad sector?

Joined
Nov 3, 2010
Messages
4
Location
NE WI
Hi. New forum member here. Please excuse me if this question has already been discussed.
I have a GO 720. I am working on it for a friend who is not very computer literate.
Background:
1- 720 stopped connecting to computer and also would not fully start up. Only goes through "TomTom" sound startup screen and stops at the green screen showing a GPS picture and a small icon of a HDD in lower right corner.
2- Will not shut off with top power button. (Sometimes shows red "X"). Will only turn off with "Soft Reset".
3- NEW battery was installed and fully charged through cradle.
4- "HOME" (v1.7.020) was installed on Windows XP machine from CD and it auto updated to version 2.7 during install.
5- Cradle has been plugged into three different USB ports, all with the same following results.
6- WIN-XP will recognize the "New Hardware" and sets up two drive letters for the GPS. One is "E" and the other is "F". (I assume the "E" drive to be a card reader slot because it asks for media to be inserted). "F" should then be the internal memory.
7- "My Computer" shows both drive letters. "E" has always asked for media, and initially "F" asked to be formated. After checking the "Hardware>Properties", I found there was no problem with WIN-XP seeing the drives. (There were no red "X's" or yellow "!'s". All was good.)
8- I formated the "F" drive in "FAT" and immediately after, the "HOME" software saw the GPS, ID'ed it correctly as a "GO 720" and connected. It then automatically started an "Update" to the GPS.
9- The main program, all the voices and the "QuickGPSfix" all downloaded properly. But when it got to the "Installing on Hard Drive" part of the install, it failed with a "FATAL" disk write error to the "F" drive. (See screen grabs attached to see full error message).
10- I did a "Safe to Remove" request to disconnect the unit from the computer and then did a "Soft Reset" with the unit out of the cradle.
11- The unit still will not fully startup.
12- Now, when attaching the GPS to the computer (same USB Port), WIN-XP recognizes it is there, "HOME" does not, and when checking "My Computer" It lists the drive letters "E" & "F" but both show "Please insert a disc into Drive E: (or F: )" and I, of course, can't run the disk utilities on either drive in this condition.

I would like to try and run a disk utility to try and have it mark the internal memory where it is apparently bad and let it reformat the memory in "FAT", but this is impossible in the current state. I am guessing at this point the internal memory itself is bad OR the controller that sends data to it is bad.
Any opinions? Is there something I can do to repair this issue or is this ANOTHER "TomTom" that has failed with a FATAL flaw?
Thanks for any comments. :)
 

Attachments

  • Screen Capture Pg1.jpg
    Screen Capture Pg1.jpg
    86.8 KB · Views: 512
  • Screen Capture Pg2.jpg
    Screen Capture Pg2.jpg
    80.8 KB · Views: 575
Last edited:
Welcome to TTF!

Have you tried a pin reset on the 720 and then reconnected to the computer? If so, is it recognized?

If you insert a 4 gig sdhc card in the unit and then connect to Home, does it recognize the card and ask what storage area you'd like to use?

You can, if possible, run everything (app, maps, voices, everything) from a sdhc card and leave the internal completely empty. If the unit recognizes an app on the card, it boots from there.
 
As I stated in the problem description, I did a "pin" (soft reset) numerous times. That technique is also needed to shut the unit off fully (sometimes).
There is a sticker covering the SD Card slot on the bottom. It states "No SD required" so I did not consider even trying a SD card.
When I get a chance to purchase a SDHC Card of the 4GB size I will give that a try. That really is a "band-aid fix" to a rather specific problem with the unit, but it is better than trashing it if DOES work. :rolleyes:
Thanks for your response. I will eventually let you know.
 
Last edited:
You may consider it a 'bandaid' fix and maybe it is but the reality is that internal sometimes can get screwed up on units and fortunately your model can use sdhc cards up to 32 gigs in size.

Considering what the model may have cost a few years ago compared with the cost of a 4 gb sdhc card costs, ot's a no brainer as far as I can see if it keeps the unit running..........
 
I don't think the OP has mentioned what firmware was on this unit, and hence, I don't think we know if the bootloader will handle 4GB (yet). Will he be offered 8.351, or 8.3xx anything right out of the shoot on a "clean" unit, or would it be one of those download and upgrade again situations for a 720? I ask because 8.3xx would be prerequisite to using the 4GB card, wouldn't it? Just considering a possible chicken/egg situation here. Might not even be an issue.
 
Close Tomtom HOME.

Use winrar to extract the contents of this file onto the Tomtom drive that has formatted properly.

When the X disappears from the Tomtom screen (signifying that the copying is complete), safely disconnect the Tomtom using the eject device in the windows taskbar.

Turn on the Tomtom. The Tomtom will likely update internal firmware and hopefully it says "no maps found".

Now reconnect to HOME, and try to format the unformattable drive (it may work after firmware update). If it doesn't work, don't worry just install everything to the working drive.
 
Hello all again,

Here is the update. Again, I am helping the owner who is not very computer literate and needed help with his unresponsive GPS.
The initial failure was a NO START issue where I found the unit was incapable of reading the internal memory. All data was lost. I loaded the "TomTom HOME" software from his install CD. It was initially ver: 1.6.020 as I recall. This version was immediately updated to the current ver: 2.7.6.2056 running on a Windows XP tablet system computer with USB 2.0 ports.
When connecting the GO720 to the USB from its dock it tried to load the software back to the GPS but had a FATAL Error. At that time the unit was unable to fully start on its own but was able to connect to the computer and attempt updating. The attached JPGs are screen shots of the FATAL Error message. (See JPGs). This message popped up as data was being written to internal memory of the GO720. This was an indication of a failure of the memory blocks. I tried to do a Windows "Scan Disk" but that would not run. After that, the unit would no longer connect to the WinXP machine.
After getting the Forum info earlier in this thread, I purchased a "Kingston 4GB SDHC Class 6" Memory card. As soon as I connected the GO720, with the SDHC card installed, to the WinXP machine, the "TomTom HOME" software started up and did the automatic upload.
I believe it initially loaded a ver: 7.?.?.???? system onto the SDHC Card. Then, on subsequent soft resets and reattachments to the WinXP system, the "TomTom HOME" software updated the GO720 to the current ver: 8.351.9982.1.
I added a few "Voices", a "Startup" and "Shutdown" screen, and a few "Vehicles" to the system. I could find no way to load any maps though.
(See also the attached .DOC file in .ZIP form for the current "System Information". This document was modified to prevent personal ID info from showing).
My current question is: How will I be able to load the unit's original "US & Canada" map set back into the unit so it will function? It does nothing without a map set installed - which was destroyed when the unit's internal memory failed. I do not know if the owner was able to do a - or did a - "Backup" of the GO720 at any time in the past. So - how do I go about reloading this unit with a map set so it is functional again? We are close to bringing this back to life! Where do I go from here?
Thanks again in advance for your help! :)
 

Attachments

  • Screen Capture Pg1 - Orig update failure.jpg
    Screen Capture Pg1 - Orig update failure.jpg
    86.8 KB · Views: 455
  • Screen Capture Pg2 - Orig update failure.jpg
    Screen Capture Pg2 - Orig update failure.jpg
    80.8 KB · Views: 422
  • Current System Info 11-14-2010.zip
    5.4 KB · Views: 385
Good to hear that you got as far as you did.

Good news / bad news. IF your "patient" did a backup at any time, or updated the original map at any time, there's going to be a copy of the original map somewhere on the PC used for those functions.

Possibility #1: User Downloaded Map or Map Update

Start by looking here on that PC:
My Documents\TomTom\HOME\Downloads\complete\map

You're looking for a folder (or folders) there called North_America_2GB (if more than one, they'll have -n appended where "n" is a digit indicating the sequence in which the folders were created).

If you can find such a folder, we can get you back up and running. Home may even be able to use it via the Manage my GO, Items on Computer.

Alternately, Possibility #2: User Did Backup via Explorer

This one, although something we preach constantly here, isn't often done by a user. BUT - if you see an entire North_America_2GB folder out on a backup somewhere, the folder can be slid right over into the root and should work.

Last ditch, Possibility #3: User Did Home Backup

If that were the case, you'd already be seeing this available in Home's Restore option. You could restore directly from Home.


That would be the good news. The bad news is that maps are keyed to individual product by serial number, so unless you can turn up a map on a PC somewhere, your friend will either have to purchase a new map from scratch or consider another unit altogether.
 
OK "canderson". Thanks for the reply.

This is essentially how I thought this would go. I just needed the path and the right name of the files that held the maps. So, we should be ready to go.
I will get back together with him and look in his computer to see if the correct map file is there. Hopefully it is. I am a bit leery about doing a restore from his computer because of the (most likely) outdated app data that would over-write all the stuff I did so far. I would rather copy the correct map data to the root and go from there.
I will post a final piece once we give all this a try.

Thanks again for your help! :D If anyone else has any comments I will be watching periodically. ;)
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
28,976
Messages
195,679
Members
67,959
Latest member
31Den

Latest Threads

Back
Top