Device on but no display Via Live 120


Joined
Oct 27, 2010
Messages
12
Location
South Wales, UK
TomTom Model(s)
TomTom One & Rider 2
Updated software inc fastfix update, device is powered on because when linked to TomTom website it recognized the device , but screen remains blank.

Tried holding power button for 30 secs which resets but still no joy!!

Any thoughts please?
 
Ad

Advertisements

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,267
Location
Toronto Canada
TomTom Model(s)
Go 50; Go 520
Can you do a pin reset on the unit [again] (think that model has a dedicated reset hole. If not, hold the power button about 15 seconds till you hear the drum sounds).

If that doesn't help, then connect to the computer and do an Explorer, not Home, backup. See here: https://www.tomtomforums.com/t17864-how-backup-contents-your-unit-computer-how-restore.html

Then delete all the loose files in the root of the unit, NO folders or their contents. Connect to Home and install the application offered. Disconnect properly from Home, using the Device Disconnect icon.

Any better? If not, afraid you have a hardware issue.
 
Joined
Feb 11, 2011
Messages
4,683
Location
London, UK.
TomTom Model(s)
Go520,720,XL Live, Start60,Go940,950,1000,1005,New500,New5000
I don't think you can do any of that on a VIA120, dhn.....

@jrisch you might want to update the models listed in your profile?
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top