620 Pro Wifi

Joined
Jul 10, 2023
Messages
2
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
620 Pro Wifi
Good evening all!

I am new here but I am struggling to find any sort of support for my issue so i thought i would see here.

I have a 620 pro WIFI however. every time i go into the settings and tap on WIFI it says in order to see possible connections please turn on WIFI. i thought this was quite strange and i have hunted all through the settings on the device as well as run two separate resets of the device to no avail.

Am i being a touch silly here and missing something entirely or do i need to send my unit back?

Thank you for responding,
G
 
Granted, mine's not a Pro model, but hey ... that's just crazy! You'd think the thing had an 'airplane' mode or something, yeah?

I assume this is a recent problem that just popped up, not one you've had all along, and that WiFi was working before.
May I also assume that if you go to 'Setting's / '?' / 'About' and scroll down to 'Data Connection', it says "None"?

Let's start from square one. What kind of 'reset' did you perform twice? Can you describe the steps you took?
 
@canderson Hello!
thank you for your reply, i have reset the device back to factory settings twice now through the unit itself as well as through my drive on my PC.
This is a recent development with the device as it did use to connect to the WIFI but now nothing. i do actually think its an issue with the WIFI antenna within the device as apparently the device is stating that WIFI is permanently off.

i do appreciate the insight into this however and thank you for your time,

:)
 
@Big Trucker G Disconnect the GPS unit from a computer and check again on the Wi-Fi screen. If no change, then contact the TomTom support team. They will take care of it 😜
 
@canderson Hello!
thank you for your reply, i have reset the device back to factory settings twice now through the unit itself as well as through my drive on my PC.
This is a recent development with the device as it did use to connect to the WIFI but now nothing. i do actually think its an issue with the WIFI antenna within the device as apparently the device is stating that WIFI is permanently off.

i do appreciate the insight into this however and thank you for your time,

:)
If the WIFI is deactivated to download maps in my opinion it means that you are no longer connected to your WIFI at home, enter your identifiers again. https://help.tomtom.com/hc/en-gb/articles/360013899580-Mettre-à-jour-votre-GPS-via-Wi-Fi-
 
It sounds as though the firmware can't "see" the WiFi chip. Not good. If you depend upon custom POI, none of the current generation devices support that feature.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
28,865
Messages
194,742
Members
67,813
Latest member
Cumbrian

Latest Threads

Back
Top