1605TM Will not charge in vehicle

Joined
May 12, 2014
Messages
3
TomTom Model(s)
1605TM
I have a TomTom 1605 TM that I have had for about 3 months. It charges fine on the PC but will not charge in any vehicle (have tried in 3 different vehicles). Can charge phones in all of them, so know the vehicle recepticals are working). The charging cord is a TomTom Model 4UUCS. The green light comes on but the unit will not work or charge.
 
Have you tried turning the key to the accessory position for about one second and then turn on to the ignition setting?
 
Just went out and tried this, - in the lower left hand corner it shows that the unit is being run on the battery. I can't remember if there was a different insignia when it was running off of the vehicle or not when I first got the unit, but it did charge and run in the vehicle even though the battery was not the power source. Do you know if that insignia changes when it is connected to the computer vs. the vehicle or battery? Really am stumped, don't know what else to try.
 
Sounds like it may be a duff charger. I'm not familiar with that TomTom model but most recent ones use a standard mini- or micro-USB 5 Volt power connection.

If the charger has one of those, do you have any other devices (mobile phone etc.) that you can try on the TT charger? Along with what you have tried already, that should definitively prove where the fault lies.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
29,078
Messages
196,573
Members
68,090
Latest member
luziol

Latest Threads

Back
Top