ToMTom XXLBattery charging Problem


Joined
Feb 28, 2011
Messages
2
On 22.2.11 I bought a new TomTom XXL. It seems to work ok ie it locks on to several satellites shows the correct position and I can set favourites. It has an indicator which shows how much charge is in the battery. The manual states that the battery should take up to 2 hours to fully charge. I have charged it continuosly several times for up to 6 hours but the indicator has never shown greater than three quarters charge.
I have had a constant dialog l with the TomTom Support Team. They have directed me to perform several software resets, and to uninstall and reinstall some TomTom software, but none of this has made any difference. I should be most grateful if anyone could help me solve this problem. I would be very interested to hear from anyone who has an XXL with a battery indicator that shows full charge after a 3 hour charge. Kind regards Stan

* Edit
* Report
 
Ad

Advertisements

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,170
Location
Toronto Canada
TomTom Model(s)
1535 LIVE; Via 1605; Go 50; Go 520
Welcome to TTF.

I moved your post to the appropriate forum. There is a bug in the application for many models such that it will never show a full battery, regardless of how long you charge it, once you disconnect from a power supply (car or computer).
 
Joined
Feb 11, 2011
Messages
4,683
Location
London, UK.
TomTom Model(s)
Go520,720,XL Live, Start60,Go940,950,1000,1005,New500,New5000
The battery *is* charged it's just the indication that's broken.
Just ignore it.
 
Joined
Feb 28, 2011
Messages
2
Thank you

Hello dhn, I thank you very very much for your prompt reply.
Does this mean that probably the only thing wrong with my TomTom is that the battery indicator is not accurate and that the battery is probably fully charged? The TomTom support Team got me to install a new version of the Application ( which did not help) is this a waste of time? I was thinking of returning my unit to the shop where I bought it, would you advise agaist this? Kind Regards Stan
 

canderson

Moderator
Joined
Dec 28, 2007
Messages
11,332
Location
Colorado, USA
TomTom Model(s)
GO720, GO740TM Live, GO 1535 Live, Via 1535, Via 1605, GO 52, GO 600, GO 620, GO 630, TomTom Bridge
Hello dhn, I thank you very very much for your prompt reply.
Does this mean that probably the only thing wrong with my TomTom is that the battery indicator is not accurate and that the battery is probably fully charged? The TomTom support Team got me to install a new version of the Application ( which did not help) is this a waste of time? I was thinking of returning my unit to the shop where I bought it, would you advise agaist this? Kind Regards Stan
No need to return it. The newer firmware won't resolve the problem. In fact, it would take an older version to change this behavior, and you'd lose the other benefits in the process.

Just ignore it as we all do. Your battery is no doubt happy.
 
Ad

Advertisements

Joined
Feb 11, 2011
Messages
4,683
Location
London, UK.
TomTom Model(s)
Go520,720,XL Live, Start60,Go940,950,1000,1005,New500,New5000
The battery *is* charged it's just the indication that's broken.
Just ignore it.
Hello dhn, I thank you very very much for your prompt reply.
Does this mean that probably the only thing wrong with my TomTom is that the battery indicator is not accurate and that the battery is probably fully charged?
Didn't you trust me? :p

:cool:
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top