tomtom go540 live help please!

Joined
Jan 11, 2013
Messages
4
i have this device..go540 live and is not connecting to my computer..
on the device's screen show the tomtom device and in right down corner it is an hard drive.. and it just stuck there..
what can i do to repair it...
go540 is old already so.. no take it back and change it.. or buy another one....low money... :|
please someone help me..
i put allready the 9.061.xxl2009_tts.CAB-navcore-XXL on a 4gb sd card and insert in tt.. restart de tt.. and nothing..

img16091.jpg

img16101.jpg



img16091.jpg
 
Your first illustration is what a 540 will look like if you hold the button down too long when attempting to start it up.

The second, and perhaps more important item, is that the Navcore you loaded to your unit isn't at ALL appropriate for a GO 540 Live. That version might be used on an XXL540, but that's a different beasty entirely. Best never to load versions of code via raw download unless you're sure which one you need.

You should solve this problem it the 'old fashioned way' by deleting all of the loose files (NO folders) on your unit and letting Home reload new firmware once or more to get you to the current version.

That is accomplished per the instructions here ...

First: Backup! https://www.tomtomforums.com/t17864-how-backup-contents-your-unit-computer-how-restore.html
Now Get New Firmware https://www.tomtomforums.com/t27294...-how-reinstall-fresh-software-using-home.html

I'd give you a direct link to the correct firmware instead, but the latest I can spot at the moment is 9.054, and I know for certain that it is NOT the most recent.
 
thank you for reply so fast!!
1.the thing is when i connect in to computer, in tomtom home is "no device connected" and is asking me for format disk and when i press format button appear "Windows was unable tocpmplete the format"and gives me this error:
http://imageshack.us/photo/my-images/228/img16131.jpg/
in the window with Format Removable Disk on capacity section isthe value is "Unknow capacity"
2. i was doing the Emergency Recovery Mode but instead the "speening cogwhell"
on the display it appear this:
http://imageshack.us/photo/my-images/521/img16141.jpg/


the first problems started with restarts of the tt, after a while he give me a disk error..
can this problem be solved? can the flash drive be replaced? or what should i do?
in computer management in portable devices it is
thank you!
 
Last edited:
Have you made the Explorer backup using the instructions in the link provided by canderson?

If so, then use Explorer to delete all the loose files in the root of the unit, NO folders or their contents. Then connect to Home. A new application should be offered. Install and disconnect properly from Home using the Device Disconnect icon.

Questions:
1. Does your model have a sd card slot? I didn't think the 540 had one.
2. The Emergency Recovery mode is not meant for Nav2 devices such as the 540 but, rather, for the newer models now sold. Why are you referring to that?
 
i "fix" my tt device!!!
1.yes it is with MicroSD slot
2.i just tried what i sow on net. :/. trying everithing i found
i downloaded tomtom truck from internet and put it on sd card
after restart .. tomtom logo appear and the soft was runing again just fine!
the problem now is the internal memory... is unable to read/write/format
i"ll try the tomtom flash cleaner... and i'll reply the result
the thing now is .. in format window. before on size section was unknow memory,now it shows hole 968mb.. but still unformatable... i'll give a try with flash cleaner to try save the memory
 
You can install everything which means application and maps on a sdhc card and the unit should work just fine as it will boot from the card.

Internal memory does fail on these devices.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
29,081
Messages
196,586
Members
68,091
Latest member
ziviani

Latest Threads

Back
Top