New 910 And Desperate

Joined
Sep 6, 2007
Messages
4
I just purchased a 910 and used it once. I tried updating it and now when I turn it on, I get a red X and nothing else happens. What do I do? I am supposed to leave for a trip on Saturday and I am desperate.

Thanks for all of your help.
 
I had the same thing to happen to my 910 about a month ago. If you have not tried to reset the unit do that first. That may solve the problem. Tom Tom support had me do that three times before asking me to download the current version of HOME and installing it. That accomplished nothing so the tech ended up determining that I needed to send the unit in for repair. Since yours seems to be a new unit you might consider returning it unless other posts may offer you a better solution. BTW my new unit, refurb I am sure, came with the previous version of maps but after the debacle with POI's in the new version I am struggling with the concept of upgrading and starting that debate again.
 
Not sure about a red x, but I did have mine stop working and the screen stayed black. I got online and found out how to reset the unit and it then worked fine.

mark
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
28,976
Messages
195,673
Members
67,959
Latest member
31Den

Latest Threads

Back
Top