MyDrive not syncing with TomTom Go on iPhone

Joined
Jul 21, 2022
Messages
8
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
Rider 500
Hi folks, using MyDrive on Mac and iPhone but having problems trying to get routes to sync. If I create a route in MyDrive on the web (on my Mac) it appears in the MyDrive app on the iPhone (so far so good). However, the route never appears on the TomTom Go app on the iPhone. I can create a route on MyDrive on the iPhone and it appears on the TomTom Go app on the iPhone and on the MyDrive on the web (after logging out and back in again). So it appears the problem is that I cannot get routes on MyDrive on the web to sync with TomTom Go on the iPhone (sorry for the long winded post). Does anyone have any ideas. Thanks.
 
yes logged into everything and for some reason only two of many routes appear on the TomTom Go app (they all appear on my TomTom Rider 400) so its definitely an issue with the TomTom Go app not syncing
 
Are you using the app to create the routes? If so, can't advise.

If you are creating them on the web (MyDrive), you don't need to run the app to get them to transfer to your device. Especially with iPhones that haven't always played well with TomTom devices over Bluetooth, I recommend just creating a WiFi hotspot on your phone and letting your TomTom access routes and POIs etc that way.
 
Thanks. Think what you're suggesting (hotspot) is to get routes onto a TomTom device, but that's not the problem - my routes are available on the Tomtom Rider 400 but they are NOT available on the Tomtom Go app on the iPhone (maybe indeed the iPhone app is useless)
 
Ah, completely misread you there. Too many apps!
I'm in kind of an odd situation where my GO app (Android) can't really be connected to my device account, so can't say for sure what happens there.
However, if I connect to the MyDrive web account that is common to my GO app, any route that I save on the MyDrive web page finds itself immediately in the GO app on my phone. Not sure why yours does not.
 
Hi folks, using MyDrive on Mac and iPhone but having problems trying to get routes to sync. If I create a route in MyDrive on the web (on my Mac) it appears in the MyDrive app on the iPhone (so far so good). However, the route never appears on the TomTom Go app on the iPhone. I can create a route on MyDrive on the iPhone and it appears on the TomTom Go app on the iPhone and on the MyDrive on the web (after logging out and back in again). So it appears the problem is that I cannot get routes on MyDrive on the web to sync with TomTom Go on the iPhone (sorry for the long winded post). Does anyone have any ideas. Thanks.
I have exactly the same problem in my GO 500. I use Windows 10 on my computer and Android on my phone. The synchronization between the computer and the application on the phone works 100%, but it does not work on the GO500. Of course, my GO500 is connected to the Internet and the MyDrive service is active. Traffic and speed cameras synchronization works OK. Only MyDrive does not sync. The problem appeared after some update of the GO500 software and is still present. I have more than 1GB free on my device. Sometimes, after many attempts, the synchronization unexpectedly performs once on the GO500 but then fails again. In my opinion it is problem with GO500 firmware.
 
Same issue over here as Bryan.
Created my own route ONLINE in MyDrive, but it does NOT sync with TomTom Go on my Iphone.
1. I am logged on in TomTom Go as well as in Mydrive with same account.
2. The route was saved with the option to sync.
3. In settings on TomTom Go the , MyDrive is switched on

I can not imagine Bryan and I are the only person's who suffer this issue, so there must be a solution for this. Anyone ?
 
Think I remember I solved this by ensuring it was a track I was trying to sync and not a route
 
Same issue over here as Bryan.
Created my own route ONLINE in MyDrive, but it does NOT sync with TomTom Go on my Iphone.
1. I am logged on in TomTom Go as well as in Mydrive with same account.
2. The route was saved with the option to sync.
3. In settings on TomTom Go the , MyDrive is switched on

I can not imagine Bryan and I are the only person's who suffer this issue, so there must be a solution for this. Anyone ?
I fixed the issue.
After saving your new route in MyDrive and selecting the sync option.
Stop the app on the iPhone one time and restart it. All routes will be synced and are visible then
 
I have the same issue. Routes are in MyDrive on the web and in the iPhone app. They do not sync to the TomTom Go app on the iPhone. One reason this didn't work before is if you create a route from your current position. If you created a route from a specific address this has worked in the past for me, though not reliably. Now routes are not syncing at all. Shame as if it worked it would be a good solution and I would even swap my Garmin GPS for a TomTom if I could trust the syncing.

I think it's just poor software but if anyone has a solution I would love to hear it!
 
I have the same issue. Routes are in MyDrive on the web and in the iPhone app. They do not sync to the TomTom Go app on the iPhone. One reason this didn't work before is if you create a route from your current position. If you created a route from a specific address this has worked in the past for me, though not reliably. Now routes are not syncing at all. Shame as if it worked it would be a good solution and I would even swap my Garmin GPS for a TomTom if I could trust the syncing.

I think it's just poor software but if anyone has a solution I would love to hear it!
Sometimes, if the route created in Mydrive does not sync, it is because your email address or password is not the same as your Mydrive account.
On your phone, Tomtom service disconnected you then reconnected you.
 
I have the same issue. Routes are in MyDrive on the web and in the iPhone app. They do not sync to the TomTom Go app on the iPhone. One reason this didn't work before is if you create a route from your current position. If you created a route from a specific address this has worked in the past for me, though not reliably. Now routes are not syncing at all. Shame as if it worked it would be a good solution and I would even swap my Garmin GPS for a TomTom if I could trust the syncing.

I think it's just poor software but if anyone has a solution I would love to hear it!
I have the same issue. Routes are in MyDrive on the web and in the iPhone app. They do not sync to the TomTom Go app on the iPhone. One reason this didn't work before is if you create a route from your current position. If you created a route from a specific address this has worked in the past for me, though not reliably. Now routes are not syncing at all. Shame as if it worked it would be a good solution and I would even swap my Garmin GPS for a TomTom if I could trust the syncing.

I think it's just poor software but if anyone has a solution I would love to hear it!
I found a workaround for the lack of sync problem in my GO500. When synchronization in GO500 does not work, I define any POI in my GO500 and then delete it. At this moment, synchronization in GO500 starts. The GP500 must be connected to the Internet at all times.
 
Same issue over here as Bryan.
Created my own route ONLINE in MyDrive, but it does NOT sync with TomTom Go on my Iphone.
1. I am logged on in TomTom Go as well as in Mydrive with same account.
2. The route was saved with the option to sync.
3. In settings on TomTom Go the , MyDrive is switched on

I can not imagine Bryan and I are the only person's who suffer this issue, so there must be a solution for this. Anyone ?
Hi Stonypony, same problem here; this can't be a NL/ regional problem ?
 
Hi folks, using MyDrive on Mac and iPhone but having problems trying to get routes to sync. If I create a route in MyDrive on the web (on my Mac) it appears in the MyDrive app on the iPhone (so far so good). However, the route never appears on the TomTom Go app on the iPhone. I can create a route on MyDrive on the iPhone and it appears on the TomTom Go app on the iPhone and on the MyDrive on the web (after logging out and back in again). So it appears the problem is that I cannot get routes on MyDrive on the web to sync with TomTom Go on the iPhone (sorry for the long winded post). Does anyone have any ideas. Thanks.
Hi Bryan,

Did you ever find a solution for this issue ?

thanks
Pete
 
I fixed the issue.
After saving your new route in MyDrive and selecting the sync option.
Stop the app on the iPhone one time and restart it. All routes will be synced and are visible then
Hi, Can you expand/explain what you mean by Stop the App on the iPhone please.
 
Don't just make the app "dissappear" it will still be running in the background. You need to swipe the app up to get rid of it and then restart it
 
Yup, done that.
Ive even deleted the app from the phone and re installed it, but still no routes.

Because recent destinations are there and because my places are there, i feel its a simple setting or a major TomTom problem. It seems that nothing i do works.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
29,078
Messages
196,573
Members
68,090
Latest member
luziol

Latest Threads

Back
Top