Map Update with MyDrive fails before completion

Joined
Apr 15, 2024
Messages
7
Country
<img src="/styles/default/custom/flags/au.png" alt="Australia" /> Australia
TomTom Model(s)
VIA 1415
I am attempting to refresh the 4+ year old Europe map on my VIA 1415 device.
I can log into MyDrive and connect the device via USB to the PC.
The download of the map completes but the Update stage to the device fails at different points, sometimes as far as 99% through.
I have noticed that the data throuput to the Tomtom via USB drops from 32mbps to 8kbps after around 49% of the download.
I have tried Win 10 and Win 11 all 64 bit versions with the same symptoms.
I have tried the USB cable from another Tomtom but have the same symptoms.
Any help will be appreciated!
 
Try clearing the Mydrive connect cache
Try to remove Mydrive connect on your computer then reinstall.
In the settings then download checked so that the map downloads first to your computer.
 
I followed your suggestions and rebooted after the reinstall of MyDrive but saw the same result.
The clear cache and reinstall forced a new log-in and the file to be downloaded again from the Tomtom server.
The device shows 'Updating - Do not disconnect your device' for the duration of the update.
Sadly it still fails with the same message at some point during the update.
 
I installed 4.4.0.5040 of MyDrive on my Win 10 PC.
Despite pressing the clear cache in settings and removing, reinstalling and rebooting the MyDrive app, it always remembered my credentials (unlike Windows 11).
There was also an error on the install: TempMDC.lnk has no application.
I don't get this on my Win 11 machines.
I got the same result during the update phase where it failed to complete after downloading the files from the Tomtom server without complaint.
 
If the map loads there would still be 2GB free on the Tomtom device.
So it's not a capacity issue, not a cable issue. Can you download and install / update something less complicated and smaller than a map? just to see if it will go.
 
Last edited:
The full Europe map is 4.6GB, so I assume there will be sufficient space without a micro-SD but I have not yet purchased a micro-SD to try.
Behind the scenes, it appears to have added a full set of voices in many languages while I have been attempting to upgrade the EU map. At one point it had mostly consumed it's storage and was asking me to choose a subset of the EU map at around half the total size. Subsequently, it had removed the corrupted portion of the EU map and freed-up the device storage again for another attempt. At this stage it appeared to have reloaded the voices.
Is there a factory reset available on the Via 1415 (I can Google) and is that worth a try?
 
Try unchecking the Mydrive connect settings so that the map is installed directly on the GPS.
 
I gave that a try but the map download is still failing.

Off to the airport now without the Tom Tom - I will get a juicy SIM card instead.

Nevertheless; Thanks to everyone for you assistance !
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
29,046
Messages
196,316
Members
68,048
Latest member
Doug Heydon

Latest Threads

Back
Top