Go Live 550 GPS Problems and restarts

Joined
Dec 14, 2011
Messages
4
TomTom Model(s)
Live 550
Hi

Can anyone help me with a problem I've recently started having with my TomTom Go Live 550 please? I've had it for a couple of years. For the last couple of weeks it's been loosing GPS signal every so often, and at other times it will suddently say I'm on a totally different road (or no road at all) no-where-near to where I actually am. It will jump around for a little bit then get back to normal (or totally loose the GPS signal). This has been happening whilst driving up and down the M6 motorway (amongst other places), in the same places that I regularly have a good signal, so I'm pretty sure it is my device and not interference/blocked signal.

Also it fairly regularly restarts it's self. More often than not it is just when it is first turned on when getting in the car, and will sometimes restart itself 4 or 5 times before it stays on. Occasionally it will restart itself after being on for longer periods of time. Some times when it restarts it just goes blank and then comes back on as if I'd pressed the power button, whilst other times it looks like it is installing itself. ie there is a progress bar that moves across the bottom of the screen. It remembers the destination I've entered before it restarted, though at times other settings change, such as if I've changed it from "Day times colours" to "Night time colours" (or vice versa) not long before it restarts then this reverts back to what it was previously.

Any suggestions on how this could be fixed, or is it likely to be a hardware fault and I need a new sat nav!

Many thanks.

Phil
 
You didn't mention but is the satnav plugged into the car charger when this happens?

In other words, do you have a charged battery?
 
Hi dhn

Sorry, yes the sat nav is plugged into the car charger. We pretty much always have it plugged in when in use, and as far as I can think it has only ever done this when plugged in.

Thanks

Phil
 
Well, you can start by making an Explorer, not Home, backup of the unit's contents. If not sure how, see here:
https://www.tomtomforums.com/t17864-how-backup-contents-your-unit-computer.html

Then delete all the loose files in the root of the unit, NO folders or their contents.

Connect to Home and install the application offered. Disconnect properly from Home using the Device Disconnect icon.

Any better?
 
Many thanks. I'm at work at the moment but will give it a try tonight and let you know how it goes.

Thanks

Phil
 
Hi

Sorry for the delay. I've just run through what you suggested, and so far everything is looking good, though I've only driving a mile or so with it. I've also had it sat on my table turned on for half an hour (no gps signal as I'm indoors) and it hasn't restarted. I suppose I'll see for sure over the next day or two.

Many thanks for all your help.

Phil
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

TomTom GO 550 LIVE 2
Go Live 550 problems 11
GO550 Live Sever Connection? 4
550 live menu 6
GO 550 LIVE / Nokia C1 contacts 2
GO 550 live/Samsung Galaxy s19000 1
GO 550 Live 2
TT 550 Live not connecting to live 0

Members online

No members online now.

Latest resources

Forum statistics

Threads
28,884
Messages
194,919
Members
67,837
Latest member
kimvandenberg

Latest Threads

Back
Top