Explorer BU saved my bacon today...

Joined
Aug 14, 2008
Messages
131
Location
SW Ohio
TomTom Model(s)
Go720
I know this is automatic for most, BUT, not sure what I did, or didn't do, to make this happen, but, today, 6 hours before a trip out of state, devide to fire up the ol 720 and make sure everything is OK.

Map that comes up is Guam..... (wtf) no more North America, no more nuthin. Have NA on SD card, Guam on internal. NO CLUE how I hosed it up, BUT I DID. :eek: :confused:

Didn't have time to mess with it, so, quickly restored the "last known good config" from my archive of explorer backups. Thank god, all was well in 7 minutes...

ALWAYS, and I do mean ALWAYS, follow the great advice on this forum and MAKE EXPLORER BACK-UPS.
I did, and I thank all for the knowledge I have learned here.

I am back "on the road". :eek:

Thank you all....
 
Did you recently download a new map of Guam?? In my case, a GO 630, downloading a map with the most current version of TomTom Home installs the map on BOTH the SD card and internal memory in one pass without giving you an option to select the location. The same thing happens with GPS fixes and Safety Cameras but not with Mapshares. I've reported this here on this forum and to TomTom. No answers yet though.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
28,893
Messages
194,968
Members
67,843
Latest member
Merciful

Latest Threads

Back
Top