Tomtom email address advice

Joined
Jan 1, 2014
Messages
17
Location
Manchester U.K
TomTom Model(s)
start 60, 5150 Truck Pro
Hi if i have posted in the wrong area i apologise
I have bought a 2nd tomtom can i register it with the same email address as my 1st one thanks in advance
 
No! Good thing you asked! For whatever reason, TomTom has chosen to link device accounts to email addresses instead of to unit serial numbers. I think it's a legacy issue from many years ago - a bad decision then that is very difficult for them to change now. So things get well and truly messed up when it comes to any map subscriptions, etc. Always provide a unique (even if dummy) email address for each unit.

Actually, now that we are using MyDrive as the PC user interface for newer Nav3 and Nav4 units, MyDrive will insist that you provide a different email for each anyway when you connect them. It was easier to screw this up in the old days when the Nav2 devices used Home as the user interface app on the PC and you could accidentally do this without warning.

Since your 5150 Truck is a Nav3, and your Start 60 is either a Nav3 or Nav4 (brilliant -- the idiots at TomTom reused that model number for an entirely different unit!) and both use MyDrive, I think you will find that MyDrive insists that you link each to a different account.
 
Last edited:
thanks i didn't know that when i registered it i used the same email address as the first one now its telling me the device isn't linked to the email address but they sent me the email to confirm activation of the free lifetime maps & the free 1year Live Subscription
 
also i have added a screenshot my device has been connected to my laptop now for over an hour & it still says 2hrs remaining and 5% done the file was only 19.1mb Any suggestions please
tomtom.jpg
 
Ouch. Please note that I added some stuff after the fact in the prior post.

MyDrive will allow you to link a device to a different account (if I recall the words correctly) every 6 months. What I believe you've done is remove the first device from the email account and replaced it with the second. If connecting the second (new) unit to MyDrive appears to be working acceptably, then connect your original one. MyDrive should say that it is no longer linked to any account. That's your opportunity to provide a new email address for the 1st unit. Let me know if that's the case.
 
also i have added a screenshot my device has been connected to my laptop now for over an hour & it still says 2hrs remaining and 5% done the file was only 19.1mb Any suggestions please
I know that it sounds ill advised when in the update phase, but when this happens, the best recourse is often to unplug and replug the unit. Do you recall what this 19.8MB content was about? A very large Mapshare update, perhaps?
 
No, we've never heard of any damage caused by the unplug/replug operation. It's had to be done many times as the only means to clear whatever constipation seems to hit this process at times.
Honestly, I've always been pretty surprised by that, but it's very possible that smaller uploads such as these are buffered in the unit and checked before they are applied.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
29,071
Messages
196,515
Members
68,073
Latest member
Womble19

Latest Threads

Back
Top