Five (5) XL330S's in 3 months!

Joined
Mar 17, 2010
Messages
34
Location
Ohio
TomTom Model(s)
XL-330-S for now
I am at the end of my rope with TomTom!:mad::mad::mad: I purchased my first XL325S at the end of November 2009. It is now March 17th and I am awaiting my FIFTH (that's right 5th) replacement XL330S from TomTom.:confused::confused:

My problems appear to run the gambit of 1st freezing up; then failing to update, then unable to write an update to the TomTom unit after downloading (which took almost 2 hrs. with DSL). :eek:

I am running Windows XP Professional SP-3 and have checked to see if I might have a virus, or malware, or a trojan and everything is clean. I used my Norton, MalwareBytes, AVG, and Avira to scan every nook and cranny. CLEAN!
So, I asked TomTom if they thought my problem MIGHT be with my XP.....no answer.

To top it all off, after receiving my 3rd unit, and it failing, and repeatedly asking for a NEW replacement not a refurbished one.....well they promised that on the fourth unit they "would then be permitted to replace my defective unit with a new one, not refurbished.....well the fourth one arrived and it was refurbished! Now I have been notified by Customer "Support" that my replacement unit has been shipped, and guess what:

"Your RMA XXXXXX-XXXXXX has been processed and shipped back to you. Your device(s) were shipped via UPS [they promised Fed Ex overnight] and the tracking number is 1ZXXXXXXXXXX [which UPS does not recognize as a good number]

Items in shipment:

1.) 1EG0.052.09 - XL 330 US-CAN Refurbished"

Any suggestions??? Garmin....Magellan???
 
Have all of these been out-of-the-box failures, or has each failed only after some sort of firmware or map update has been attempted?
 
Unit #1 (the original 325) was after a month or so..... Units 2, 3 4 were out of the "box" failures. Who knows about the one in transit to me.....
 
Last edited:
I am at the end of my rope with TomTom!:mad::mad::mad: I purchased my first XL325S at the end of November 2009. It is now March 17th and I am awaiting my FIFTH (that's right 5th) replacement XL330S from TomTom.:confused::confused:

My problems appear to run the gambit of 1st freezing up; then failing to update, then unable to write an update to the TomTom unit after downloading (which took almost 2 hrs. with DSL). :eek:

I am running Windows XP Professional SP-3 and have checked to see if I might have a virus, or malware, or a trojan and everything is clean. I used my Norton, MalwareBytes, AVG, and Avira to scan every nook and cranny. CLEAN!
So, I asked TomTom if they thought my problem MIGHT be with my XP.....no answer.

To top it all off, after receiving my 3rd unit, and it failing, and repeatedly asking for a NEW replacement not a refurbished one.....well they promised that on the fourth unit they "would then be permitted to replace my defective unit with a new one, not refurbished.....well the fourth one arrived and it was refurbished! Now I have been notified by Customer "Support" that my replacement unit has been shipped, and guess what:

"Your RMA XXXXXX-XXXXXX has been processed and shipped back to you. Your device(s) were shipped via UPS [they promised Fed Ex overnight] and the tracking number is 1ZXXXXXXXXXX [which UPS does not recognize as a good number]

Items in shipment:

1.) 1EG0.052.09 - XL 330 US-CAN Refurbished"

Any suggestions??? Garmin....Magellan???

Sorry about all of your problems. I purchased SL 330S six days ago. I've been testing it on every little auto trip and it's been almost flawless. So far, it seems like a good $100 investment. I have not, however, hooked up with the TT Home software because of all the warnings on this forum. Could that be your problem?
 
It would not surprise me if the TT Home software is causing the problem. How do you plan on updating your unit with latest GPSFic and MapShare, etc. Or, are you choosing that it is not necessary. I felt the same way about the $100 investment, at the time.
 
Couple of thoughts:

1) make sure the Tomtom is directly plugged into your computer (and try a different cord). Tomtom's are flakey at times if they are behind a hub.

2) When you get the Tomtom, close home and do this type of backup. Then turn off the Tomtom and hold the power button forever until a black and white debug screen shows up. If the bootloader line shows 5.5128, then use winrar to extract the contents of this file onto the Tomtom, then disconnect it and power off/on so the update sticks. If any other bootloader shows up, then skip the prior step. Then turn on HOME, plug into the computer, and see if that helps.
 
MVL - see other thread https://www.tomtomforums.com/general-tomtom-discussion/21203-how-important-tomtom-home.html

Before we start to manually (or with Home) modify his unit, we need to be certain he's even got clean backups of the original this time and assure the unit is stable as-shipped. With this many bricked in a row, I don't want to see him having to send another one back.

Edit: In fact, it's tempting to merge the two threads since they're focusing in on a single user's issues. Note in mod forum.
 
Last edited:
Yup, that's why the "explorer backup" was the first step.

Bootloader 5.5128 is horribly unstable, causing numerous file I/O issues. I suspected that was the problem, and hopefully the below fixed it for good.
 
I have heard that 5.5128 was OK, but that 5.5130 was the train wreck (in particular, USB issues), and that moving forward from 5.5128 to 5.5136 (jumping over 5.5130) was the ticket.
 
Hey all, I'm back! Just wanted to say (3 more replacement units later....) that I bit the bullet and purchased a Magellan. My wife said that I did not need all the stress that I was getting with no help from Tom Tom.

Thanks everyone for trying to help me!

:cool:
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Members online

No members online now.

Latest resources

Forum statistics

Threads
28,888
Messages
194,956
Members
67,842
Latest member
M Stedman

Latest Threads

Back
Top