GO6200 the word TOMTOM flashes on screen every 2 seconds and will not start


Joined
Sep 24, 2019
Messages
1
Country
<img src="/styles/default/custom/flags/au.png" alt="Australia" /> Australia
TomTom Model(s)
GO 6200
Has been on computer charge all day, tried holding power on button down for a few seconds to many seconds but the flashing continues throughout. Tried holding the power button down whilst plugging in to power. Same flashing result. Rather disappointed in a relatively new machine. All helpful suggestions appreciated.
 
Ad

Advertisements

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,232
Location
Toronto Canada
TomTom Model(s)
Go 50; Go 520
Try holding the power button for 30 seconds until you hear the drum sounds. If that doesn't work, try support:

Australia
1300 135 604
Monday-Friday:9:00 am to 5:30 pm AEST
 
Ad

Advertisements

canderson

Moderator
Joined
Dec 28, 2007
Messages
11,499
Location
Colorado, USA
TomTom Model(s)
GO720, GO740TM Live, GO 1535 Live, Via 1535, Via 1605, GO 52, GO 600, GO 620, GO 630, TomTom Bridge
Sounds as though it's not charging properly. Have you a wall adapter that you can use that produces more power? Your PC likely generates only 500mA, even if things are working well, which they may not be.
Alternately, you could connect it in vehicle while powered off for a longish (15 minutes or more) trip to see if it behaves differently after using the vehicle power to charge.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top