xulrunner.exe failed

Discussion in 'Technical Support' started by Buddy_Shivley, Feb 8, 2008.

  1. Buddy_Shivley

    Buddy_Shivley

    Joined:
    Jan 19, 2008
    Messages:
    4
    Likes Received:
    0
    I am trying to install tomtom home and after downloading and trying to start, i get the error message "xulrunner.exe failed with error 0: process failed to start up correctly. If this problem persists, please reinstall from http//tomtom.com/home" which i have done 3 times with no success. Help, please.
     
    Buddy_Shivley, Feb 8, 2008
    #1
    1. Advertisements

  2. Buddy_Shivley

    Bakpain

    Joined:
    Dec 26, 2007
    Messages:
    44
    Likes Received:
    3
    Location:
    Lake Worth FL
    TomTom Model(s):
    TomTom One XL
    Bakpain, Feb 9, 2008
    #2
    1. Advertisements

  3. Buddy_Shivley

    jpzsports

    Joined:
    Jan 2, 2008
    Messages:
    5
    Likes Received:
    0
    I have the same problem

    I contacted TOMTOM support, but they haven't helped at all.

    I get the error when the program is starting so I can't even get into the program. - The error occurs on the startup of Home 2.2

    What do I do?
     
    jpzsports, Feb 16, 2008
    #3
  4. Buddy_Shivley

    bjtodd

    Joined:
    Feb 17, 2008
    Messages:
    1
    Likes Received:
    0
    1) uninstall Home
    2) do a Windows Restore to a point BEFORE the first time you tried installing Home
    3) install the latest version from the website

    it may give you trouble the first time it runs, but restart it (reboot if necessary) and it should be alright after.

    Having said all that, I've found that Home won't communicate with my TT on my Toshiba laptop -- it will work on my wife's Dell laptop and my work computer :confused:
     
    bjtodd, Feb 17, 2008
    #4
  5. Buddy_Shivley

    Dave Burton

    Joined:
    Feb 19, 2008
    Messages:
    2
    Likes Received:
    0
    SOLVED: "xulrunner.exe failed with error 0" on Windows Vista

    Are you running Windows Vista?

    I got this message, too. So I uninstalled, and then re-ran the downloaded TomTomHOME2winlatest.exe file again, but the second time I ran it "as administrator." That time it worked.

    To run it "as administrator" you need to right-click on TomTomHOME2winlatest.exe, and pick "Run as administrator" from the menu, instead of simply double-clicking it.

    This technique is often necessary for programs that were intended for Windows XP or earlier. My guess is that the TomTom folks haven't bothered to update their installer and web page with proper instructions for Windows Vista, though I can't imagine why it has taken them so long. My (freshly downloaded) copy of TomTomHOME2winlatest.exe is version 2.2.0.33.

    Regards,
    Dave Burton
    Cary, NC
    www.geeksalive.com
     
    Dave Burton, Feb 19, 2008
    #5
  6. Buddy_Shivley

    Tim25

    Joined:
    Jan 15, 2008
    Messages:
    149
    Likes Received:
    7
    Location:
    Virginia
    TomTom Model(s):
    One XL S
    SOLVED: "xulrunner.exe failed with error 0" on Windows Vista

    I had the same problem after TomTom Home updated itself while I was running Vista logged onto a non-admin account. I logged into my admin account, TTH successfully updated itself...and it worked once again on my non-admin account.
     
    Tim25, Feb 22, 2008
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.