XL 340 won't start up


Joined
Jul 15, 2016
Messages
3
Country
<img src="/styles/default/custom/flags/us.png" alt="United States" /> United States
TomTom Model(s)
xl 340
I have tried the reset. The drum sounds come on but the screen stays black.Any ideas? It has worked perfectly for the several years I've used it and this is the first time this has happened.When I connect it to my computer and go to the properties it says that the device is working properly. I'm confused! o_O
 
Ad

Advertisements

Arno

Moderator
Joined
Jun 3, 2008
Messages
3,677
Location
Toronto - Pickering, ON
Country
<img src="/styles/default/custom/flags/ca.png" alt="Canada" /> Canada
TomTom Model(s)
930; GO 620; Start 63
Was that the reset where you insert a paper clip or the like into the small hole at the bottom.
Also, try to charge the device over night.
 
Joined
Jul 15, 2016
Messages
3
Country
<img src="/styles/default/custom/flags/us.png" alt="United States" /> United States
TomTom Model(s)
xl 340
Mine doesn't have a hole on the bottom. I had to hold the on/off button for 20 seconds. I will leave it on charge overnight and see what happens. The green light is on that's on the bottom of the device.
 
Joined
Jul 15, 2016
Messages
3
Country
<img src="/styles/default/custom/flags/us.png" alt="United States" /> United States
TomTom Model(s)
xl 340
I think it's shot. The first step in most everything is to turn it on. Thing is it won't turn on. Only the drum roll then a bit of static, but nothing on the screen. :(
 
Ad

Advertisements

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,170
Location
Toronto Canada
TomTom Model(s)
1535 LIVE; Via 1605; Go 50; Go 520
Try keeping it connected to the computer for a few hours. Device can be off.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top