xl 340 freezes on start up and I delete my map folder


Mar 21, 2010
So my 340 was working great for the past 4 months and I updated it with no proplems.

1st problem was the time was set wrong

2nd the unit asked for my language preference then would hang on the selection and never finish booting up

3rd now it will get to the second screen of booting up and freeze

4th I deleted my map folder from the unit in hopes of tomtom home downloading the folder again and fixing the problems.

Please can anybody help or did I screwmyself royaly
I hope you have a back up (Explorer, hopefully) of your unit's contents, especially the map folder.

If so, format the unit, not quickformat. Copy back the map folder. Connect to Home and you should be offered an application. Accept and install.

If you didn't make a backup but you HAVE updated the map from the original that came on the unit, then the updated map in compressed format will be found here:
c:\documents and settings\yourname\my documents\TomTom\Home\Downloads\Complete\Maps\

In that case, format the unit, connect to Home and get the application when offered. Install. disconnect properly from Home using the Device Disconnect icon. Restart the unit and connect to Home again. Move to Add Maps. You should see the map listed. Select and install.
Thanks for the reply dhn..... since my last post and from doing alot of reading on the forums I have made some changes that have helpped.

1st I can operate the unit in TT home

2nd I have downloaded the latest maps, made a complete backup with explorer and have removed the loose files only no folders. Reconected to TT home downloaded the new file...

Now when the unit boots up I get the select Language screen, and then a few prompts for setting the right hand or left hand oeration, miles/kilometer, time settings. If I go thru these prompts and selct done at the last page the unit rests and I have to repete the process again.

This is the exact sceniero that caused all my problems to begin with and that is when I tried but failed to fix my unit and I started this post.

Any suggestings from this point would be great!! Thanks!
Okay, you have the Explorer backup.........

Connect the unit to the computer (don't start Home) and download and run (3 times) the Clear Flash tool found here.

If that doesn't help, then reformat the internal. Not quickformat. And restore your backup.
ok, doing the fat 32 and restore now... I will up date when its done. Thanks for your time on this matter thus far!
the gps unit is still not working on its own, it will not get past the splash screen....
Got the refurbed TOM TOM the other day....

Turn around time was faster then expected and they included all the accesories they told me to keep.

I updated the gps to the newest maps and what ever else
Tom To home wanted to update... took about 3hrs to download/update the gps...

Seems to be working just fine...

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Latest member

Latest Threads