version 9.025.477770.2 of software causes touchscreen issues

Discussion in 'Technical Support' started by Towerblock, Jan 1, 2010.

  1. Towerblock

    Towerblock

    Joined:
    Jan 1, 2010
    Messages:
    8
    Likes Received:
    0
    Hi all,

    I purchased a TT 335s and 340s in the last 3 weeks. After updating using that latest map guarentee and also updating to the latest TT application, BOTH of these devices became very slow to operate. I thought the touchscreen was defective on the 335s which is why I bought the 340s. The 340s touchscreen and overall response when operating the device was much faster. After updating the 340s using Home it became a dog just like the 335s. After a little experimentation and investigation here is what I've found.

    1. Called TT, they claim they've never heard of issues with the Touchscreen (especially the volume slider) being jumpy or unresponsive

    2. I reverted both devices back to version 8.415 of the TT application and they run beautifully again! Very snappy response, map overviews draw faster, volume slider works well, POI's are searched much faster etc.

    3. You are able to use version 8.415 of the TT application software with the newest maps, as that is what I have on both of these devices.

    I am not sure if there are any drawbacks to running version 8.415 of the software, but if anyone knows of any please let me know. For me, it makes a huge difference in how well the touchscreens "respond". If anyone is in the mood to experiment, please try the different versions of the software and let me know if you have similar findings.

    Also, I am very happy with the TomToms at this point. For the money I love the routing features and they work really well.
     
    Towerblock, Jan 1, 2010
    #1
    1. Advertisements

  2. Towerblock

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    22,912
    Likes Received:
    435
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    Navcore 9.025 was never meant for your model. While it improves the installing time, it can create other problems, as you've noticed.
     
    dhn, Jan 1, 2010
    #2
    1. Advertisements

  3. Towerblock

    hamilb

    Joined:
    Dec 31, 2007
    Messages:
    63
    Likes Received:
    1
    Location:
    Shrewsbury MA USA
    TomTom Model(s):
    VIA1530,XXL550,ONE140S,125
    I believe that 9.025 IS meant for the 340S and the 140S.
    I have the 140S with 9.025 and also see that the volume slider is 'balky'.
     
    hamilb, Jan 1, 2010
    #3
  4. Towerblock

    Towerblock

    Joined:
    Jan 1, 2010
    Messages:
    8
    Likes Received:
    0
    hmm...tomtom Home added 9.025

    Interesting..How do you know it wasn't meant for the 340s or the 335s? Basically I installed home, turned on the devices and home updated both of the devices to 9.025. I didn't "ask" it to.

    Is there somewhere that you got your information that I can check out?..:) I'd guess that there are lots of other people out there with 9.025 running on their 340s'...:(
     
    Towerblock, Jan 1, 2010
    #4
  5. Towerblock

    Towerblock

    Joined:
    Jan 1, 2010
    Messages:
    8
    Likes Received:
    0
    Thanks!

    Now I know it's not just the two that I have..:) If this thread gets enough responses, next time I call tomtom I'll send them to it so they can figure out what is going on with the software.
     
    Towerblock, Jan 1, 2010
    #5
  6. Towerblock

    mvl Moderator

    Joined:
    Dec 19, 2008
    Messages:
    5,433
    Likes Received:
    61
    Location:
    Boston, MA, USA
    TomTom Model(s):
    GO 2535 LIVE, GO 1535 LIVE, GO 740 LIVE, Go 930
    There is a version 9.025 for the ONE 140 and XL 340, as many members have posted about HOME offering it. Based on the file download names, there is a version specifically designed for the ONE and XL models.

    What's confusing is that Tomtom's UK changelog website says it's only for the European GO x50 models, although that can't be correct because Tomtom makes separate GO X50 downloads and ONE/XL downloads.

    8.415 is sufficient to fix USB corruption, so you don't need 9.025 for that bug. The 9.x application is a brand new platform, and typical with Tomtom, they'll need a few months to iron out the bugs. The key advantage that I can see for ONE/XL owners on 9.x is that you favorites will get saved when installing new maps.
     
    mvl, Jan 1, 2010
    #6
  7. Towerblock

    Towerblock

    Joined:
    Jan 1, 2010
    Messages:
    8
    Likes Received:
    0
    MVL, Thanks..

    mvl, thanks for the explanation. It's funny that you are aware of this but tomtom's own tech support was not able to explain this. What I'm glad to hear is that I'm fine sticking with the 8x versions of the software for now!

    Thanks again for your help. I'll give them a cpl more go arounds to iron out the bugs. I'm a programmer as well, so I'm pretty used to new software not quite being ready for prime time..:)
     
    Towerblock, Jan 1, 2010
    #7
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.