Unable to update

May 13, 2010
I've been having this problem for a long time now. I've used different versions of the TomTom HOME software and tried on different operating systems and every time I get the same error. I have a TomTom ONE v.2 and I have had it since around 2007 but when I connect it to my computer and start up the TomTom HOME software it automatically scans for updates and I get the loading status bar for a few minutes and then every single time I get this same error and these details.

Report incident ID: 22171987
ERROR: DesktopLib/DeviceItemScan/Error: Error during scanning for navigation items Device Item Scanning std::exception: bad allocation.
@ .\framework\DeviceItemScannerThread.cpp(84)

in .\framework\DeviceItemScannerThread.cpp:84
0. function errorAbortTask chrome://tthome/content/logic/ttTask.js:508
1. chrome://tthome/content/logic/dllUtils.js:77
2. chrome://tthome/content/logic/dllUtils.js:69

I get the same type of error trying to update as when I try to click the 'Add Maps' button. I have tried to find whatever solutions I could though the support page but nothing ever works. Hopefully there is a solution to fix this so I can get my TomTom updated finally.
Last edited:
Do you have dot net framework installed on your computer? Check in the add/remove programs icon of the Control Panel.

If not, get it from here. Install it and see if that helps.
I tried to install on two different computers one running windows 7 and the other XP and still I get the same error as before when I connect my tomtom to my computer and try to update.
Try making an Explorer, not Home, backup of your unit's contents. Then format your unit, not quickformat. Then restore your backup. See if that helps.
I haven't had the chance to try anything else to fix the problem for a while but what exactly do you mean by an explorer not home back up. I don't quite understand what to backup before I try and format the device.
but what exactly do you mean by an explorer not home back up..

One of the options in your TomTom HOME software is Back up.
Do not use it.

After you connect your TomTom to the computer you use Window Explorer to see the TomTom as a separate Hard Drive letter, typically like Removable Disk (G:) (or TomTom + a drive letter, usually higher than D).

Make a new Folder in the C:\ drive (or one of your other HDDs), Name it TomTom_BU (or anything you are comfortable with; I call mine BU_before_map850 etc,).
Now right click on your TomTom device drive letter, select Copy put your mouse over the new folde you made and right click Paste.

It will take a little time to complete the copying, don't interrupt it.

After it is finished have a look at these two folders and compare to see if they have copied.

Once you are satisfied that you have a full copy you can make the changes you wanted with your TomTom, knowing that should there be a screw up you can always put the original back onto your device.

Do not hesitate to ask questions if you are not certain.
Someone here will try to help.
One last question before I do anything just to double check so I don't do something stupid. After I have the backup of the Tom Tom contents when I go to format the actual device itself I format by right clicking and doing the windows format drive option?

Also, once the format is done what would I need to do to restore everything back onto the device to get it working properly.
To format the device simply right click the drive letter associated with the device in Windows Explorer, from the pop up choose "Format" make sure the "Quick Format" checkbox is NOT selected then click Start.

To copy the files back to the device simply locate your back up folder, open it and highlight all the lifes and folders with the mouse, right click and select "Copy" now right click on the drive letter associated with the device and select "Paste" all the files will now be coppied to the device - Mike
Well I did the reformat and restored the backup files and tried to update my device again only to get the same error again. I don't know what else I can do, but not being able to update the devices and the maps is starting to effect me using it in certain areas.
Any other way I can get my device to update besides what I tried? I tried all the listed troubleshoot ways listed on the website and nothing works so far.
I am having a similar problem with mine as well. I have a TomTom XL 340. I have tried everything. I have reformatted the TomTom, uninstalled Home, tried different versions of home, had my unit replaced by tomtom (since it was under warranty), and completely reformatted my computer and reinstalled everything on it. I have literally wanted to pull my hair out over this. When I called TomTom support they didn't have any answers for my issue and replaced it for me. I just got the replacement yesterday and the replacement is doing the same exact thing over and over. I just tried the suggestion above and this is the error I got when i updated. It is the same error I have been getting! If anyone has any info it would be beyond helpful as I am about to buy a Garmin if I can't resolve this!!!!

ERROR: HomeBase/IO: Error writing file: F:\data.chk
@ .\portable\cfile.cpp(1947)
in .\portable\cfile.cpp:1947
0. chrome://tthome/content/ui/bindings/commit.js:82
1. chrome://tthome/content/ui/bindings/ttwizard.xml:1061
this._commitFailed(i, commitPage);
2. chrome://tthome/content/logic/util.js:79
return func.apply(obj, arguments);
3. chrome://tthome/content/logic/dllUtils.js:77
4. chrome://tthome/content/logic/dllUtils.js:69
Last edited:

I too got that message after doing up dates which i also got 3 virus's from
now when i try to update i get a message f:\data.chk and cannot go any further
these updates i done about 2 weeks ago
Windows thinks any file with an extension of .chk is a recovered corrupt file but TomTom's application is linux based and the extension .chk represents something else entirely.

The data.chk file is vital for proper functioning of the unit and shouldn't be meddled with or deleted.

1. Make an Explorer, not Home, backup of your unit's contents.
2. Remove all the loose files in the root of the unit using Explorer. NO folders or their contents.
3. Connect to Home and accept the application offered. Install it.
4. Remove the unit properly from Home using the DEvice disconnect icon.

See if that helps.
I have already tried this. Why did it suddenly start doing it when it didn't do it before? If windows thinks it's a corrupt file it should have done it everytime I updated the application in the past? That file has been on every update that I have got it to install.
When you did your formats, did you disable quickformat?

Also, what application is on your device? The following apps cause drive corruption and you need to upgrade off of them as fast as possible?
- app 8.081 through 8.082
- app 8.411 through 8.414
I have the exact same problem since yesterday.

stupid TomTom Home was trying to place a map on my unit when it stopped. Afterwards it was corrupted which was fixed by the procedure tomtom derscribes.

also did the format and stuff but every time i even try to normally copy something on to it it gives me this error again in tomtom home.

I have no normal maps folders of the maps i purchased so i cannot manually put it on. My backup couldn't be made manually anymore as TT home messed it up.

i am going insane here as i know a bit about some stuff but this i don't get and every time i ask tomtom support they give me the same stupid answer: backup, format, install again...."yeah, as i said (and even copied all the error code) that gives me an error!"

anyways, i didn't read an answer here yet. Anybody has brilliant ideas?

BTW: using 8.083 --> for me this also creates corruption abviously
Last edited:
Well, you could try this:

1. Make the Explorer, not Home, backup of your unit's contents.
2. Your purchased map should be here:
C:\Documents and Settings\yourname\My Documents\TomTom\HOME\Downloads\complete\maps\
3. If so, after making sure your backup IS on the computer, format the unit's drive. don't use quickformat.
4. connect to Home and you should be offered an application. Accept and install. Disconnect properly, reconnect to Home and see if another application is offered, if not then again disconnect from Home properly (using the Device disconnect icon on the bottom right of the screen).
5. Start the unit and hopefully it'll boot up to the No Maps found message.
6. If so, connect to the computer but do NOT start Home.
7. Use the info in this link:

8. After installation, disconnect from the computer properly and boot up. Does it work?
9. If so, make another Explorer backup.
Error writing file E:\data.chk

I've tried all of the suggestions and I'm still getting this error when coping to my hard disk. I've also spent about 2 hours on the phone with tech support and they have no answers as well. Having the same problem with two different XL350M units.

Any other suggestions will be greatly appreciated!
Have you tried:

Connect to the computer. Make an Explorer, not Home, backup.

Then use Explorer to delete all the loose files in the root of the unit. NO folders or their contents.

Go here:

c:\documents and settings\yourname\my documents\TomTom\Home\Downloads\ and rename Downloads to DownloadsOLD.

Then connect the unit to Home and install the application offered. Disconnect properly from Home using the Device Disconnect icon.

Does that help?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Latest member

Latest Threads