TT Rider not connecting to Win 10 PC

Discussion in 'Technical Support' started by LemansII, Feb 25, 2019.

  1. LemansII

    LemansII

    Joined:
    Feb 25, 2019
    Messages:
    8
    Likes Received:
    0
    TomTom Model(s):
    Rider (2013)
    hi,
    i've just joined this forum hoping that some one can help me with this problem....

    I have a TT Rider from about 2013, which uses TT Home to connect to PC for map updates etc...

    At some point in the past, the Rider stopped connecting to TT Home on my PC. might have been when i upgraded to Win 10, but i can't be sure.

    The Rider connects fine to my Wife's Win 10 PC. (Win 10 64 bit Professional)

    on my PC, i have tried all sorts of uninstall, inc. with Revo, as recommended on this forum, installing in Win 7 and Win 8 compatibility modes, installing / running as Administrator.
    None of this has solved the problem.

    on my PC, i can see the Rider as an external drive, and the Rider asks if i want to connect to a PC when i plug the cable in, so seems like the Rider is okay?

    However, it doesn't auto start TT Home, even though Home is set to start when a device is connected.

    I'd be really grateful for any ideas on what to look for specifically on my Win 10 PC that might solve the problem.

    thanks
    Martin
     
    LemansII, Feb 25, 2019
    #1
    1. Advertisements

  2. LemansII

    Arno Moderator

    Joined:
    Jun 3, 2008
    Messages:
    3,155
    Likes Received:
    71
    Location:
    Toronto - Pickering, ON
    TomTom Model(s):
    930; GO 620; Start 63
    While grasping at straws, have you tried to start Home2 first before USB connecting?
     
    Arno, Feb 25, 2019
    #2
    1. Advertisements

  3. LemansII

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    10,557
    Likes Received:
    163
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    I guess question #1 is not whether Home appears to see your Rider, but does the computer itself see it? It should appear as an external drive to the OS.
    If not, we need to sort that first, since Home would never have any reason to auto-start if no device is being detected by the OS.
     
    canderson, Feb 26, 2019
    #3
  4. LemansII

    LemansII

    Joined:
    Feb 25, 2019
    Messages:
    8
    Likes Received:
    0
    TomTom Model(s):
    Rider (2013)
    thanks guys,
    to Arno's response, yep, tried starting home manually, then connecting TT (several times) - no success.

    and to canderson's question, yep the TT is visible as an external drive in Windows 10 file explorer, and i can navigate the TT folder structure.

    This is why it's weird - the PC can see the TT, and the TT knows it's connected to the PC, because it ask to connect to the PC !!
     
    LemansII, Mar 3, 2019
    #4
  5. LemansII

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    10,557
    Likes Received:
    163
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    So what we have is good and bad. If the PC recognizes the device and allows you access to its content, that's a very good thing. That eliminates a whole host of problems.

    We're down to the issue of what happens when it's connected. When Windows sees the device connect, it should be trying to 'handle' that by figuring out what it should do for the specific USB VID/PID (the vendor and product ID that is communicated by the device to the PC) of the device that connected. The registry contains a list of all of the USB devices that were ever connected to the machine, and the registry also contains the associated action (in the way of driver/software) that should be taken whenever the device is connected. It seems that this is the step that isn't working properly.

    We know that Windows is correctly handling the TomTom as a USB external storage device, or it wouldn't be possible to see and manipulate the contents of the TT with your PC.

    That rather leaves us with the conundrum of why Home isn't being called to handle the device when it connects, and why, if manually executed, Home still can't see a device that 'belongs' to it.

    I guess that we need to first be sure that the VID and PID identifying information reported by your device still makes any sense. I am attaching a program called USBDeview. It can be run from anywhere on your PC. When executed, it will bring up a list of every connected USB device on your Windows box. Go ahead and run the program, then connect your Rider to your PC. Watch for the new entry to appear in the list. The vendor ID should be "1390" (that one belongs to TomTom). I'm not sure what the PID will be for a Rider since I've not connected one here, but that's OK for now. Please report the following:

    Device Type, Serial Number, Vendor ID, Product ID, USB Class, USB Subclass, ParentID Prefix, Service Description, and Instance ID.

    That should show me if you have any anomalous stuff there, and if you are prepared to go the last step to have a look at the registry for problems, the "Instance ID" will tell us where in the registry the specific USB entry is for your Rider device.

    I have to attach the program as usbdeview.zip.txt (it is NOT a text file!) because the board will not allow zip or exe attachments. When you download the file, change the name to just usbdeview.zip, unpack it, and run the *.exe file that is inside.
     

    Attached Files:

    canderson, Mar 3, 2019
    #5
  6. LemansII

    LemansII

    Joined:
    Feb 25, 2019
    Messages:
    8
    Likes Received:
    0
    TomTom Model(s):
    Rider (2013)
    hi,
    thanks very much for the detailed response,

    I've run the utility and got the following:

    Device Type, Mass Storage
    Serial Number, K44473A00026
    Vendor ID, 1390
    Product ID, 0001
    USB Class, 08
    USB Subclass, 06
    ParentID Prefix, blank - no entry
    Service Description, @usbstor.inf,%USBSTOR.SvcDesc%;USB Mass Storage Driver
    Instance ID USB\VID_1390&PID_0001\K44473A00026

    i noticed in the list of USB devices that the 'connected' column is showing 'no' for the TT, but then no others are showing as connected either.

    i used regedit to search for the instance id as above and found an entry with this string

    Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\DeviceClasses\{a5dcbf10-6530-11d2-901f-00c04fb951ed}\##?#USB#VID_1390&PID_0001#K44473A00026#{a5dcbf10-6530-11d2-901f-00c04fb951ed}

    and
    Deviceinstance set to
    USB\VID_1390&PID_0001\K44473A00026

    hope that all helps a bit ?
     
    LemansII, Mar 3, 2019
    #6
  7. LemansII

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    10,557
    Likes Received:
    163
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    Well, that is enlightening, and on the whole, good. The device's identification is at least partly registered in the registry for VID/PID and serial number of the device. So all agree on that much.
    However... I am concerned that you do NOT see any ParentID Prefix with USBDeview

    If you search the registry for 'VID_1390', you should be finding it in more places.

    While it is correct that it appears in HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\DeviceClasses\{a5dcbf10-6530-11d2-901f-00c04fb951ed}\##?#USB#Vid_1390&Pid_0001#K44473A00026#{a5dcbf10-6530-11d2-901f-00c04fb951ed}\#

    It should appear here as well in the enumerated devices
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\

    There, you should see an entry for HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\USB\Vid_1390&Pid_0001\K44473A00026
    and the details for that entry should include a ParentIdPrefix of 6&5c78914&0 or something to that effect.

    If that information is missing, we will want to uninstall the device from the USB list of connected devices, then plug it in again and see if it will register completely.

    What version of Windows are you running?
     
    canderson, Mar 3, 2019
    #7
  8. LemansII

    LemansII

    Joined:
    Feb 25, 2019
    Messages:
    8
    Likes Received:
    0
    TomTom Model(s):
    Rider (2013)
    hi, I'm running Windows 10

    just looked in the registry for
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\USB\Vid_1390&Pid_0001\K44473A00026
    and in this location there is no ParentIdPrefix item
     
    LemansII, Mar 4, 2019
    #8
  9. LemansII

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    10,557
    Likes Received:
    163
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    I would recommend using whatever method 10 is using to access Device Manager, and with your Rider connected, locate the entry for it in the USB device list -- then using right click/Uninstall to uninstall the Rider. That SHOULD wipe out any registry entries for the device. This will allow you to reinstall the Rider as a USB device (unplug/replug) to see if you can set the registry straight again for that device.

    If there are multiple "USB Mass Storage Device" entries shown in Device Manager in the USB devices list, you should be able to right click on each of them and check the 'Details' tab to find the VID/PID/Serial of your Rider so you know you are deleting the correct item.
     
    canderson, Mar 4, 2019
    #9
  10. LemansII

    LemansII

    Joined:
    Feb 25, 2019
    Messages:
    8
    Likes Received:
    0
    TomTom Model(s):
    Rider (2013)
    hi ,
    just tried that, and didn't seem to work,

    unplugging the Rider and plugging back in again didn't seem to fix it,
    but I've now discovered another issue. not sure if it's related?

    when i manually start up Home, it comes up with the message 'critical update needed ...... '
    when i try to run the install for the update it errors out with the message "the wizard was interrupted before TTH could be completely installed."
    could this point to an issue with Home ?
     
    LemansII, Mar 5, 2019
    #10
  11. LemansII

    LemansII

    Joined:
    Feb 25, 2019
    Messages:
    8
    Likes Received:
    0
    TomTom Model(s):
    Rider (2013)
    tried running home as administrator, didn't work either - same error
     
    LemansII, Mar 5, 2019
    #11
  12. LemansII

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    10,557
    Likes Received:
    163
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720 GO 740 GO1535 GO1605 VIA1535 GO 600
    Want to check on something you said two posts back .. "just tried that".
    By that, do you mean uninstalling the USB device from Device Manager, and then plugging it in again and letting 10 reinstall the Rider?

    OK - on to Home issue. Sounds like you can't get the latest Home version up and running. If it's stuck trying to update, then it won't be in a position to respond to a device, either.
    What happens if you go for the most recent version of Home directly from TT? Here? >> http://us.support.tomtom.com/app/answers/detail/a_id/5122/~/installing-tomtom-home
    I assume it isn't the most recent version that you already have, or it wouldn't be trying to update.
    Of course, you will want to completely uninstall Home (again) first. Revo Uninstaller seems to work best to assure nothing remains.
     
    canderson, Mar 5, 2019
    #12
  13. LemansII

    LemansII

    Joined:
    Feb 25, 2019
    Messages:
    8
    Likes Received:
    0
    TomTom Model(s):
    Rider (2013)
    yes, correct,
    uninstalled the usb device, unplugged rider & plugged in again. still have no device connected.

    on Home,
    I used Revo to delete, then installed the latest version from TT website, as per link above.
    don't get the 'need to update' message, but still have the same 'no device connected' error
     
    LemansII, Mar 5, 2019
    #13
  14. LemansII

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    22,835
    Likes Received:
    423
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
  15. LemansII

    LemansII

    Joined:
    Feb 25, 2019
    Messages:
    8
    Likes Received:
    0
    TomTom Model(s):
    Rider (2013)
    unfortunately not, the TT web pages only cover the basics - I've been through all of them - well feels like that.

    very suspicious also that Home won't start from the icon tray,
    I have to go to the start button.
    seems like a problem with the Home install, even though I used Revo to uninstall it (twice !!)
     
    LemansII, Mar 7, 2019
    #15
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.