tomtom xl30 screen wont respond

Aug 30, 2012
TomTom Model(s)
the unit appears in perfect shape no damage to screen or plastics

i can get it to restart by holding the power button for about 15-30 secs
it shows the legal info but cant hit continue, when plugged into a pc it shows the computer connected screen (y/n) but wont respond

it can be recognized by the pc when powered off and reset whild plugged in

i tried, uninstall/reinstall tomtom home and update the unit, still same results

the clear flash tool didnt seem to do anything, says it installed but i dont see it in program files or desktop shortcut
ran through these steps with the tomtom plugged in and recognized

any other ideas?
thanks in advance


in uninstalled tomtom home, renamed the tomtom directories in users and program files

reinstalled tomtom home and let it update the tomtom

from this
Tomtom Acting Up? -Part 1 - First Steps In System Recovery

1. soft reset
same results

2. rewrite mapsettings.cfg
tomtom home emultaor works fine (change home and modified favs)
same results with the actual tomtom

3. delete mapsettings.cfg from the tomtom us&ca folder
same results

4. clear flash too
same results

5. windows chkdsk no errors
same results

6. ran 'chkdsk e: /x /r' from the cmd prompt, no errors
same results

7. factory reset
cannot do that from the unit
and tomtom home has the factory reset greyed out

8. restore backup
i do not have a working backup on a pc

Tomtom Acting Up? - Part 2 - How To reinstall *fresh* Software using Home

i did all of that, no luck
deleted all files from the root of the tomtom drive
(i always view all hidden/system files with extensions)

still no responce from the touchscreen

is there a way to test the screen to see if it is working?
Sorry no-one else has carried on where I left off.

i don't know of any way to test the screen other than by tapping it, I'm afraid!

Beginning to think it's a hardware problem with the screen digitiser.
If you ook on eBay, you can buy replacements of the whole screen+digitiser combined or just the digitiser (cheaper but a bit trickier to fit).

As a last resort before buying one, you could try the recalibration process described here, but that's usually just for when the screen taps are producing a misplaced response, so I doubt it will be much use to you.


the screen recalib didnt seem to fix it either, id rather not take it apart since its under warranty yet
i can probably repair it, but if the service dept has all the equipment to test it properly

i finally got RMA authorized, now i just need to find the recipet and send it in

thanks again for the help before i need to do that

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question