TomTom XL freezing on startup (was "4et03")

Jan 30, 2012
TomTom Model(s)
Have a Tomtom that will not power up. It starts the process, but will not pass the Tomtom screen with 2 hands in a circle. Have tried to reset, but no luck there. Any other helpful ideas??
Last edited by a moderator:


model: 4ET03

It's printed just above the reset hole! The bar code reads C_NOGJ4360B10046. underneath that it reads (4ET0.002.03)
Do you normally use Home2?

When you connect to the computer, do you see the contents of the unit as an external drive? If so, look for a ttext file called ttgo.bif in the root of the unit (not in any folder).

The second line will show the device name.

And, talking about a reset hole ......... have you tried resetting the unit?


Okay, back to the problem.......

1. Make an Explorer, not Home, backup of the unit's contents. If not sure how, see here:

2. Delete all the loose files in the root of the unit, NO folders or their contents.

3. Connect to Home and install the application offered.

4. Disconnect PROPERLY from Home using the Device Disconnect icon.

Any better?
I have backed up the files. I have deleted the loose files off of the Tomtom. how do you install TTHome to device?? I still have same trouble as before, it freezes after the drums
You need Home 2. Get it at at

Install it and connect your device to the computer and start Home 2. It (Home) should recognize the application is missing and offer the application again.That's step 3 from my post above.


Home 2 goes on your computer, NOT on the device.
I have exactly the same problem on the same device ("Tomtom XL" acccording to ttgo.bif file). I tried following the instructions in this thread but device still freezes on the "hands" display when it's started up. It had been working fine until I tried downloading the latest map updates (I hadn't done this for ages). The download aborted and demanded that I downloaded Tomtom Home 2, which I did, then download apparently completed successfully but the device is now dead. I've tried resetting it using the reset button on the device lots of times, and holding down the on/off switch (which does nothing).
Anybody any ideas, please???
Thanks for the suggestion but no joy. Since I didn't make any backup until I had a problem in the first place (of course I regret that now) aren't I likely to have a problem with restoring that backup? Got it to a state where it told me I had no maps at one point but when I fuly restored it, it froze again. Is there any way I can restore it to factory settings (with original maps), or any files/folders I can replace selectively?


I think you misunderstood, I tried exactly what you said. Had a couple of problems reformatting for some reason but eventually it was successful. But having tried all that it still freezes on the opening hands logo.
Thanks the way I just tried your other suggestion from earlier in the thread of deleting all the files in the root directory and letting Home 2 install an application update. Unfortunately this also left me with the same result, and also seems to leave me with some files missing from the root directory. So I'm pretty stuck!
XL Live crash

My XL Live crashed after I updated last night and have the same issues. Will not get past TomTom Hands. Have done the jungle drums reset and still keeps rebooting. I do get a green screen. Will try thread suggestions tomorrow.


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question