Tomtom xl 350t help please

Mar 17, 2012
i cant access the device..i dont know if i did this wrong, when i first launch tomtom at my pc it asks me to update some files, i also update the latest map, i tried to install it but it says it has no free space, so i deleted the old map ( i made a back-up for the map ) and tried to install the new map, so when i try to add a new map it says the map cant be used in the device untill its activated first

btw when i tried to add a map the file size is around 1.7 gb ( old map?), and the new map i download is around 1.6 gb, but when i add, only map appears is the 1.7 gb which is the old map right?
it gives me an error it says "problem with map, you cannot use this map on this device, usa_canada_mexico_p-165"
First of all, try running the Clear Flash tool found here: and run it 3 times.

If that doesn't help, your new downloaded map will be found in compressed format here:
C:\Documents and Settings\yourname\My Documents\TomTom\HOME\Downloads\complete\maps\

1. Make an Explorer, not Home, backup of your unit's contents. If not sure how, see here:

2. Then delete any map folder you see on the unit.

3. Next, manually install the downloaded map. See here:

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Latest member

Latest Threads