TomTom XL 340 Live - Unknown Device

Joined
Oct 18, 2011
Messages
6
Hello everyone,

I saw a few other threads with something similar going on (but they're kind of old now) and the proposed solutions didn't work for me.

I have a TomTom XL 340 Live IQ Routes Edition GPS. On the bottom sticker, it shows up as a Canada 310 / XL Live. On the TomTom Software, it's a 340 S.

Anyway, problem I have is that the device no longer connects to my computer. It comes up as 'unknown device'. I've tried 3 cables, 3 computers, using Windows 7 x64 Ultimate, Windows XP, and Windows XP x64. I've tried it without installing any software at all (since it's supposed to show up as a flash drive) and that doesn't work at all. All of my thumbdrives work just fine, so it's not a computer driver problem.

This happened after I tried using TomTom Home software to try to write a route to the GPS. After I did, it errored out as it said 'no maps installed'. After which, I couldn't gracefully disconnect the GPS from the TomTom Home software. Leaving the GPS connected, I powercycled it and when it comes back on, it now shows up as an 'unknown device' for every computer it's plugged in to.

I get this screen:

untitled_clip_image008.jpg


But not this one anymore:

untitled_clip_image006.jpg


It sits there and spits out the 'unknown device' error on every computer and cable combination I have.

This also comes with the RDS traffic receiver and that no longer works either.

I've tried the 15 second software reset which didn't work... tried the reset factory defaults which didn't work. Tried combinations of both which don't work.

The device works perfectly otherwise - I can still map myself anywhere without issue. However, map updates no longer work, I cannot add any content at all, and because this device doesn't have a flash card to utilize, I have no other way to access the device period.

Is there a way to make this thing format itself completely to re-enable the ability to access the internal flash memory?

I had also done a couple of updates before trying to write the route from the software which took just fine.

After performing the factory reset, I noticed 2 custom icons I had loaded were still there... I thought doing that was supposed to eliminate ANY custom content including icons and the like.

The device still recognizes that a computer is attached. It'll ask me if I want to connect, I say Yes, and then it reboots and then it would normally come up to the screens above but then it stops and I don't get the second screen, and then it spits out the unknown device. If I disconnect the USB cable in this state - it WILL load and then go back into the regular GPS mode.

I've tried the soft reset while it was off and then powering it on... tried the soft reset while it was on and then letting it cycle on and off... tried the reset while connected to the computer, tried the reset disconnected, tried the reset connected to the RDS traffic receiver, tried connecting it to a USB hub and without it... I cannot get this thing to show up as anything but 'unknown device'. The error message Windows spits up is:

USB Device not recognized - One of the USB devices attacahed to this computer has malfunctioned, and windows does not recongize it. For assistance in solving this problem, click this message. Tried all the general windows troubleshooting, but it does this on all of my computers (and I have almost a half dozen).

I don't have a problem cracking this thing open. I've done it before as I had dropped the unit and cracked the digitizer, so I needed a replacement screen, which I did myself. I tried running the unit out of battery power to see if that would make it reset too and that was a no-go. I could always try disconnecting the battery, but I'm sure this is a software problem.

I'm at a loss. I tried other 'tricks' such as tapping the screen as it powers on to see if there's a different diagnostics screen built in (I've already seen the DOS based one where it gives you serial numbers and the like). It bugs me that there is no external way to access this thing at this point. Any suggestions or recommendations will be most likely, as my warranty is almost up. I got it around Christmas last year and this thing has kind of been a curse. :(
 
About the only thing left is the Clear Flash tool found here:

Clear Flash tool

Connect the unit to the computer and run ClearFlash 3 times (it is just the act of 'installing' ClearFlash that actually causes it to function).


Report back with the results.
 
Hello again,

Nope, doesn't work. The Clear Flash tool requires the GPS to be recognized by the computer, in which case this doesn't work. I tried it anyway as a shot in the dark but no good. The GPS is completely inaccessible from any computer I connect it to. Unless there's some internal command that I can execute via the touchscreen itself to format and restore the internal USB driver, this thing is a brick.
 
Just to be clear. When you say 'soft reset', you DO hear the drum sounds as the unit reboots?
 
Yes, I do. I've tried several different 'resets' some of which play the drums, others do not. If you continue to hold the power button after the drums, it takes you to some kind of black statistics screen where you can't do anything except read the available information.

I've tried the reset where you hear the drums (and then let go) with the device connected to the computer, without it, with the RDS cable connected, with the USB cable plugged in but not connected to anything... all of that doesn't work. It still comes up as an 'unknown device'. I cannot access the internal flash memory of the device at all because of this, and there's no other way to do so, unless there's like a micro sd card inside the device that I can remove and stick in to an adapter to broom it. When I had it opened before, the only card I saw was the SIM card itself. No other cards.

I'm now just trying to find a way to format the whole thing (wipe the internal flash memory) from the device itself. I see ways of doing it if it'll talk to the computer (using the TomTom software), but not from the device itself. I can't find a service manual online anywhere either.

I'm ready to run it back to the store and see if they'll take pity on me and just exchange the device, but then I'm going to have problems getting the free map updates transferred to it.

If I could talk to one of the techs who actually FIXES these rather than a customer service rep, I might get somewhere.

I appreciate the prompt responses... hopefully you know of some trick to get this thing to reconnect to the computer.
 
Not a pretty situation. From all of the detail you have been able to provide, it sounds as though you have the first case I've heard of a device misidentifying itself to the operating system that cannot be managed with a hard reset.

The bad news is that the requisite code and USB identification information is in the boot code of the device. That's why you are able to reload firmware after formatting the device. Even with no visible files on the device at all, it is expected to provide a recognizable (and correct!) VID, PID and other information to the host.

Here's what I would like you to do for me, and it should be done on the XP 32 machine to which you said you had access. Let's see what Windows is seeing reported by your 340:

Plug in the unit. Follow these tracks and tell me what you find when you get there:

Control Panel / System / Hardware / Device Manager / USB controllers

You should see your TomTom appear there as an "Unknown device"

Right click it and select Properties
Click on the Details tab and leave it on Device Instance ID
Advise all that you see on the line starting with "USB"

From the drop down, now select Service from the dropdown and tell me what you see.
 
Here ya go,

Device instance ID: USB\VID_0000&PID_0000\5&920FCD3&0&1

That's the only line there.

For your other request of Service,

That menu is empty.
 
I have a TomTom XL 340 Live IQ Routes Edition GPS. On the bottom sticker, it shows up as a Canada 310 / XL Live. On the TomTom Software, it's a 340 S.

Amongst all your other problems, that's one bit you DON'T need to worry about.

"Canada 310" is not a model name. It is just a Canadian telecoms standard (like the FCC in America) for "Licence-exempt Radio Apparatus
(All Frequency Bands): Category II
Equipment" which the TomTom needs to adhere to.

More details here (but I'd advise you not to bother! :lol:)
Canadian Radio Standards Specification 310, Issue 3,

What you have got is an XL 340 and the "S" means it has text to speech voices.

Now I'll hand you back to canderson.....
 
hahaha.

Anyway, I went through the windows registry and found the keys. Using Device Manager, I tried uninstalling the 'unknown device' which makes those keys disappear. Tried scanning for hardware changes and it does re-detect the device... as an unknown device again. I've tried forcing it to use the usbstor.inf file with no luck.

Considering this thing bricked itself while trying to load an itinerary, I created one and deleted it from within the device. Didn't work.

The RDS radio receiver is non functional too. I can plug it in and it won't detect it. It did ONCE and then never again (and I've tried repeatedly).

It's as if the device doesn't know how to handle it's own USB port.

I've let the battery drain completely from the device in hopes that if there was a hung application in memory would automatically quit... no luck there either.

I've tried both versions of the TomTom software (Home and the other, newer one). No go.

I'm debating on editing this things registry key (under the unknown device) to see if i can force it to use usbstor, but again, the device doesn't load beyond the cable screen (where it's supposed to give a warning about unplugging it... never makes it there anymore).

I'm not going to return this until early November... I need it for one more trip.

Again, this thing works, but map updates are useless.

I let the Live services deactivate, so there is no cellular services operational with the unit right now. I figured on not spending the money on it since I don't use this all that often (maybe a couple times a year).

Any other suggestions?
 
Here ya go,

Device instance ID: USB\VID_0000&PID_0000\5&920FCD3&0&1

That's the only line there.

For your other request of Service,

That menu is empty.
OK. I'm moving my previous comment from "Not a pretty situation" to "butt ugly". None of the 'normal' steps seem to be helping you, and with a vanilla XP system and a new cable, it points very strongly to a problem with the device alone. The null VID and PID indicates the failure of the device and Windows to properly communicate any of the requisite USB information when the unit is plugged into a USB port. Windows isn't seeing the vendor ID, the product ID, or even what kind of device it is. And as I noted, that should all be coming from configuration data that is available specifically to the boot code.

Being unable to connect to your computer will prevent us from using any of the normal tools and procedures by which we might even attempt reloading firmware (which comes with a bootloader attached). Further, unless the firmware you would download has a bootloader more recent than what is on your unit, I don't think it is going to try to reload it in any case.

I do not personally have access to any tool with which to force a reload of the config data for your bootloader.

IF this unit is still under warranty, I would call TomTom immediately for an RMA and get that unit replaced. TomTom can manage any update subscriptions you have in the course of exchanging the unit.
 
That's what I was afraid of. :(

Well, I guess I'll get in touch with TomTom and go through 400 steps that are useless, 10 steps that are relevant, and 3 hours of struggle in order for them to say, "Yup! It's broke!"

Fortunately they state that these come with a 2 year warranty.

Thanks for your prompt responses and the help throughout today. I'll continue to fuddy duddy with it until I can RMA it early next month.

If by some miracle it comes back to life (which I don't expect), I'll let you know if it was something I tried or did.

I even tried using Linux to connect to it. No dice. :(
 
I would start by advising them that you have tried several cables and computers, that the clear-flash and resets have not worked, and that computers are reporting a null vendor ID and product ID, indicative of a USB communications failure - inability to communicate any useful data across the port. If the tech you first contact isn't 100% aware of the consequences of the sum of those actions, DO ask for someone with more experience to help short circuit the silly script.
 
I was having the EXACT same problem described in this thread with my TomTom XL 340S

ANYWAYS - my data cable was lost so I replaced it with a generic I ordered online. The problem was the cable I ordered had a connector that was a little too fat to plug into the gps. At least I thought so. I wouldn't ordinarily force something in as hard as I did for fear of breaking one or both devices but I was able to get it in. That's when I got stuck at the same part you were. I believe that the problem is that some of the usb connectors were making contact and some weren't. The error correction in the USB standard might have been the cause of the computer *thinking* a usb connection was there even though no valid data was getting through.

To those of you suffering from this problem: Make sure your USB cable is firmly seated in the device and not coming up short. Of course if the USB plug on the device itself is loose you have bigger problems.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
29,142
Messages
197,010
Members
68,190
Latest member
Chrisanson

Latest Threads

Back
Top