TomTom write I/O error??

Sep 17, 2011
Hi, I got a second hand TomTom One, 3RD Edition, and I have the latest TomTom HOME Software on my Windows 7 PC. If I copy files into my device through explorer, I get an I/O device error. If I try to update my TomTom via TomTom Home, It gets the following error about writing H:\System:
ERROR: HomeBase/IO: Error writing file: H:\system
@ .\portable\cfile.cpp(1947)
in .\portable\cfile.cpp:1947
0. chrome://tthome/content/ui/bindings/comm?
1. chrome://tthome/content/ui/bindings/ttwi?
this._commitFailed(i, commitPage);
2. chrome://tthome/content/logic/util.js:79
return func.apply(obj, arguments);
3. chrome://tthome/content/logic/dllUtils.j?
4. chrome://tthome/content/logic/dllUtils.j?

Can anyone tell me why my device is unwritable (or whatever the problem is), and what I can do to fix it? Thanks.


Do you have a backup of what is on the unt? Especially the map?

If so, try formatting the unit. Do\n't use quickformat. Then try restoring the backup.

You can also try running chkdsk on the unit
Thanks for the reply. I can't seem to make backups through the usual backup & restore option in HOME but I did make one through 'mnage my devide' and then copying everything in the list to my computer. What you said about formatting seems to be similar to this File Access Error when saving settings to device

I will try following the instructions listed here, and will report back on what happens
TomTom One error

Well I did that flash memory clear thing, but upon creating a backup, I get this:
ERROR: DesktopLib/FileCopy/Error: An error occurred. Unable to create the files required to copy this item to your computer.
@ .\controller\FileCopyThread.cpp(161)
An error occurred while reading this file: "H:\voices\data110.bmp"
An error occurred while writing to this file: "C:\Users\John\Documents\TomTom\HOME\Backup\ONE\Backup01\InternalMemory\voices\data110.bmp"
The file or directory is corrupted and unreadable.

in .\controller\FileCopyThread.cpp:161
0. chrome://tthome/content/ui/bindings/commit.js:82
1. chrome://tthome/content/ui/bindings/ttwizard.xml:1061
this._commitFailed(i, commitPage);
2. chrome://tthome/content/logic/util.js:79
return func.apply(obj, arguments);
3. chrome://tthome/content/logic/dllUtils.js:77
4. chrome://tthome/content/logic/dllUtils.js:69

I guess I should format now?
FORMAT error

OK, thanks for that. I did the backup, and started the Format. But, about 90% of the way through formatting, windows suddenly said 'the format could not be completed', and left me with an empty devide (even unformatted). So I try formatting again, but it just won't start formatting. Help :S



I solved it!! It works like new now.

For anyone else having the same problems of no Updating or I/O device error:
What I did was: Did a manual explorer backup of the WHOLE thing. Format on FAT, (not FAT32), default alloc. size, and quick format. It worked in 5 seconds, and TomTom HOME recognised it and asked to update (ttsystem). I did this along with a foreign voice, it restarted and there were more updates. It did all of these updates SUCCESSFULLY!! NO I/O DEVICE ERROR!! brilliant. I then copied all the folders *THAT WERE NOT ALREADY ON THE TOMTOM* *NO OVERWRITE*, From the backup, to the device. I then safely disconnected, booted it and it all worked :D
Glad what you say has worked for you, but NORMALLY the format used by TomToms is FAT32, not FAT and we always recommend a FULL, not QUICK format. :rolleyes:

Life is never black and white! :)
Used 2Gb SD Disk to overcome ONE XL Format Issue

My ONE XL was corrupted during a Map Update which resulted in a 'file read error" which in turn prevented access to all maps etc on the device

I have spend two weeks following endless instructions from Tom Tom support (which were basically reformat or forget it).

After trying all of the options including restoring backups, formatting the device etc... I have managed to get it going again by formatting a 2Gb SD Disk to Fat 32 and simply reloading my maps and settings onto the disk....

So far it seems to be working..... Hope this helps


@AJW4217: Sounds like you developed problems with the internal flash (it happens). What you did is good - it's what we've recommended to others lucky enough to have an SD slot on a unit that has these issues. FWIW, the unit boots off the external card preferentially. If you're unit had working and populated internal flash, it would still boot of your SD card.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question