Tomtom via 110 stuck at splash screen...

Joined
Jan 18, 2011
Messages
5
Hello. I have a tomtom via 110 which stuck at the boot logo. Bought it in this condition hoping to update/reload the software through MyTomtom but computer does not see it neither Mytomtom application does. Also have tried the reset/recovery method: also with no success-tomtom does not enter the recovery mode or the black configuration screen, no matter how long I hold the power button pressed for.
Battery is fully charged, there is no reset pin or memory card slot in case someone would ask.
Any ideas how to restore it to be useful again? It's in great condition and would be shame to throw it away...
Best regards to all
 
Apart from letting the battery run down completely then re-charging and trying again, there's not a lot you can do if the emergency recovery mode won't work.
 
Apart from letting the battery run down completely then re-charging and trying again, there's not a lot you can do if the emergency recovery mode won't work.

Thanks for that, I have had a look at the mainboard and disconnected the battery several times. Where is the tomtom system core stored?
(I mean Linux, not the navi application). Is it CPU stack or ROM memory? I am asking because if there is broken connection between memory chip and the mb, I could try to reflow it...
Thanks
 
There's no visibility to the file system on these Via units, much less the operating system itself. 'New' designs aren't always the best.

When you say you've tried 'reset/recovery method', do you mean holding the power button until you see the diag screen, releasing immediately, and then pressing the power button quickly 3 times?
 
Hi. Yes, I held the power button for few minutes and nothing happened-still on splash screen. If I hold it loger, it restarts (drums sound and splash logo (see 1st pic.)).
 
Sorry, I just saw that I didn't insert any images...
That's how it looks like:
imag0440h.jpg
 
So you never get to the screen with white writing on a black background?

Try again and keep holding it past the 'restart with drums'
Hold it down so hard your finger hurts!

If you can get to that screen, THEN you need to tap the power button three times 1-2-3.

After that, connect to MyTomTom, to recover it.

More details and pictures here:
New style TomToms - Emergency Recovery Mode
 
None at all. If holding the button down starting from the splash screen doesn't eventually bring up the black and white text diag screen, I have no idea how one would get the device to load the backup version of the code.

Back to Halford's with it!
 
Back to Halford's with it![/QUOTE said:
Mine went the same - stuck at the startup screen. TomTom support said it would need repair - but at £88 and as the live services were about to expire didn't cost much more to buy a new one - so I did.
Have since contacted a repair firm in London who said it would be a firmware fault and cost £40.
Shame the new one isn't any better at connecting to Live Services.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
29,146
Messages
197,060
Members
68,199
Latest member
Boothy

Latest Threads

Back
Top