tomtom shuts off even with charger connected

Discussion in 'Hardware and Peripherals' started by osaeed, Jun 10, 2009.

  1. osaeed

    osaeed

    Joined:
    Apr 17, 2008
    Messages:
    6
    Likes Received:
    0
    Hi everyone. I have a Tomtom GO720 GPS. My father accidentally broke the original charger that came with the tomtom to plug into the car. So in the house he found a wall plug that had the same end connector and cut it off. he took the cable that he cut off from the wall charger and connected it to the car charger (smoke plug)

    I told him not to do that, as there may damage the gps from too much voltage. So, he connected some wires like red, white black and there was smoke coming from the charger port on the gps. I told him HALT/ STOP its smoking.

    He had to go back to his work and I tried to turning the gps on and nothing would work. I opened up a lot of other electronic items like the wii, ps3, xbox 360, lcd monitor etc and I did some repair to them. So I decided to find the issue instead before throwing it away. I opened the Tomtom up and I found a small chip that was burned/crisped. I rip the chip out since it was destroyed and WALA it turned on and everything worked perfectly EXCEPT it would not charge when connecting to the pc via usb or in the car.

    I went to get the original tomtom usb auto charger and plugged it in the car and it doesn't stay on. The unit was working with the battery, until i used it a lot and battery drained.

    So my question was how can i use the tomtom gps just with the auto charger that goes in smoke? If i pull the battery out you think that may work? I just want to use the charger only.

    Thank you.
     
    osaeed, Jun 10, 2009
    #1
    1. Advertisements

  2. osaeed

    Bama Rambler

    Joined:
    Dec 31, 2007
    Messages:
    185
    Likes Received:
    5
    Location:
    South Alabama
    TomTom Model(s):
    Go 720 with 920 POI's
    You're lucky it worked at all. Could you upload/download using the cradle after this happened.

    That charger he broke is actually a converter that converts 12v to 5v and has an extra wire for regulation I believe. So just finding a plug that fits won't work. Now that the damage is done there are only two possibilities.

    1) send the unit to a repair facility and see if they can repair it.

    2) rig up some way to directly charge the battery (which may also power the unit if you can get it to fit in the case).

    Sorry to say but it looks like your unit is hosed.
     
    Bama Rambler, Jun 11, 2009
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.