TomTom One IQ Routes - great hardware - terrible software!

Joined
Jul 5, 2009
Messages
9
Location
UK
TomTom Model(s)
TomTom One IQ Routes Europe
Hey guys, I just wanted to talk about my experiences with the TomTom One IQ Routes Edition Europe.

I purchased the device a few days ago. For driving it has been great. It's fast, it's accurate, the IQ routes seems intelligent, the voices are clear, the car holder is great, GPS fixing is fast.

The problems I have been having with the software are on the other hand monumental. Thanks to the latest maps guarantee I wanted to install the 830 maps on my TomTom. Well, it downloaded them and then gave me an error message basically stating that the file I downloaded was corrupted. I contacted TomTom support and they of course gave me some form reply that was worthless (I followed their instructions word for word and it still didn't work). I tried on anther computer, just to make sure I wasn't doing the wrong thing.

I opened up 7-Zip and did a check on the large zip file. Sure enough the file was riddled with CRC errors. I managed to download a program that fixed the errors in the file and then I installed the maps on my device with no problems. Apart from the fact that it took like 2 hours. Is the One IQ still USB 1? It certainly feels that way, as when I am installing stuff it copies at 500 KB/s. Urgh.

Then everything worked fine for a little while until I decided to install some extra voices. So I install some and it works fine. I find some more, install those and the TomTom s stuck in the boot screen. I hard reset the device. Same error. I search the internet and find that the only way of fixing this problem is pretty much by formatting the device. So I did that and it starts working again. However when re-installing I had the problem that the cab file containing the firmware for the TomTom One was also corrupted. Ahhrg. Somehow I managed to hack the firmware back onto the device again ...

Then I tried putting the voices back on .. and hey presto the device is buggered again. I am starting to get a little sick of this whole ordeal. Sadly enough all the other Navigation devices on the market don't seem to be anywhere near as good as the One IQ Routes at the same price point, so I think I will be sticking with this buggy thing for now.
 
Were you using a wireless connection when downloading the map file? That method is known to cause problems when dl large files such as a map. Try it again using a direct connection.

I know that the Go series of TT's utilize the USB 2 functionality while the TT One's used the USB 1.1 for file transfer. I would assume your model being a newer one, would also use the 2.2 methodology.

Use Explorer to view the contents of your unit. How much space is reported available on your unit? And how many voices were you trying to install? You might want to use Home to remove items from my unit and remove ALL of them. Then, just add back one voice for a while and see if the unit acts up. If ok, try a second.

Before doing any of the above, make an Explorer, not Home, backup of your unit. Ensure hidden files/folders are showing.
 
The XL_IQ and the newer XL_IQ_Live both use a USB 1 connection which does take ages to copy the large map files to/ from the device - Mike
 
Really? I'm surprised the XL-Live would still use 1.1. Mike, is the hardware on both the XL and XL-Live basicly the same then?
 
I have never opened the XL_IQ or XL_IQ_Live to see if they are different but there will be a few extra bits in the Live version for the Sim card and GPRS modem, but I do know that they take ages to copy everything from the device to the PC, using the same port on the computer for the x20/ x30 or x40 is much much faster, so these units are using USB-1 rather than the newer USB-2 - probably another cost cutting/ profit related reason why this was done - Mike
 
The USB connection wouldn't cause corruption on the map zip file, as the Tomtom only gets an unzipped copy.

If you're getting crc errors on the large map zip file, you need to work on tweaking the reliability of your internet connection. It's probably the same reason your app/voices are corrupt as well.

Attempting to "repair" crc errors on a zip file isn't very safe. Most repair tools aren't lossless, so although you can get the file to extract, the actual map contents are probably corrupted. You're better off re-downloading the map until the zip reports no errors.

Try the tools at broadbandreports.com - they have many tweak tools that you can adjust to minimize packet loss and other internet errors.

Then, try renaming My Documents\TomTom\HOME\Download to My Documents\TomTom\HOME\DownloadOLD

Then you can go back to home and redownload everything. Try 7-zip on the new downloads to see if it is error-free.
 
Wow, thanks for the prompt feedback and reply guys.

In response to the internet connection being the problem. At first I downloaded the map pack over the wireless, but then I downloaded it over the wired connection, as I thought I would follow the TomTom support teams instructions to the word:

If after the map has downloaded you find that it has not installed correctly, or you get an error message, then please do the following:-

STEP 1 Check your Internet Connection

- Make sure that you have a fast broadband Internet connection, ideally 2mb/s or higher
- Check that you are not at the end of a British Telecom exchange. If you are, then you will find that you are not receiving your advertised Internet connection speed and the connection will be unstable. This can mean that any large downloads via TomTom Home may time out and not download fully.
- Make sure that you are connected to the Internet via a Network cable and not wirelessly. You can plug a network cable into the back of your Router and connect it to the network card on the back of your computer. Also, if you connect wirelessly, you have an extra layer of security which can interfere with downloads.
- Please ensure that your firewalls are configured to allow TomTom Home to connect to the Internet fully.

STEP 2 Reinstall TomTom Home

- Download and install TomTom Home from : TomTom, portable GPS car navigation systems
- Open TomTom Home 2.4
- Click on ?Remove Items -> Items from My Computer?
- Tick the option for ?Applications?
- Tick the option for ?Maps?
- Click on ?Remove Selected Items?

STEP 3 Make a manual backup of your device

- Connect your TomTom to your computer and switch it on
- On a PC, create a new folder on your desktop and call it 'Backup'
- On a Mac, create a folder on the desktop and call it 'Backup'.
- On a PC, Open 'My Computer', you will see the TomTom as a removable storage device, e.g. TomTom (E:), double left click into it.
- Click on Edit -> Select All, then click on 'Edit -> Copy'
- Go to your Backup folder on your desktop that you have created, double left click into it and click on 'Edit -> Paste'

- On a Mac, you will see the TomTom device on the Desktop, double click into it.
- Select and copy all of the contents of the TomTom device.
- Go to your backup Folder that you have created and double click into it.
- Paste all the files into the backup folder.

Please also look at the following webpage in how to do this:-
TomTom, portable GPS car navigation systems - Support home - Select your product

*IMPORTANT*

Only proceed with Step 4 and 5 when you have successfully completed a manual backup of your device. If you are unable to do this, please contact us immediately.

STEP 4 Remove the Map Folder from your device

- Connect the TomTom to the Computer
- Browse the contents of the TomTom via 'My Computer', (on a mac, click on the desktop icon for the TomTom disk)
- You will see the Files and folders for the TomTom.
- Delete the map folder e.g. Western Europe, or Western and Central Europe, or United Kingdom and Ireland

STEP 5 Download your Latest map Guarantee

- Open TomTom Home
- Log in to your TomTom account
- Click on Tools -> Use Latest map Guarantee
- If you see a map available for download, click on 'Get it Now'.

The map can take a few hours to download depending on the map size and your Internet connection.

If you find that your map is taking more than 5 hours to download or the Download does not install correctly, then unfortunately your Internet connection is preventing the map from downloading correctly. Ideally, you will need a faster and more stable Internet connection.

The reason why I don't think that my wireless is at fault is because I have downloaded bigger files over this connection with no problems whatsoever. Ubuntu, Windows 7 RC, Movies, Music, Games etc.

In connection with the voices: The reason why the unit buggered up was when I removed the voices manually from the unit by deleting the files data76.chk, data76.vif and data76.bmp. Am I doing something wrong?
 
While other servers seem to be ok with wireless connections for dl their software, TomTom servers seem to have issues. Not sure why.

If you restore those files you deleted (you do have an explorer backup, I hope), then does the unit act ok?
 
The unit is acting fine at the moment with the Euro map I downloaded and fixed with the program called Zip Repair Pro. After reading what you have said, I think I will try downloading the map again, just to be safe. Everything else downloaded fine and installed with no errors.
 
In regard to the original title of my post. After finding out that the device is actually USB 1.1 I think I have to revise my statement that the hardware is "great". Seeing that USB 1.1 was released in 1998 and USB 2.0 is from 2000 the fact that a device released in 2009 has such old tech in it is kind of horrifying.
 
Perhaps (only a guess here) there are problems running USB2 on a 266mhz processor. Tomtom had USB2 support for a few years on its 400hmz chips (GO models), but none of its 266mhz models (usually ONE/XL) had USB2.

I don't remember any old pentium 266mhz with USB2 either.
 
Last edited:
Hmmm, I don't think that's the issue, seeing that you can get way slower hardware with USB 2.0 support. My Cowon iAudio 5 for example sported a Sigmatel STMP 3520 chipset running at a whopping 75 Mhz and it still supported USB 2.0. ( Spec Sheet )

The problem I think is that TomTom hasn't actually changed the One series internally at all in the last 5 years and have just been building on the same platform, possibly shrinking the size of internal components and releasing better, smarter firmware for the devices with much better maps. I just think it's a shame that it only has USB 1.1, as I am sure that the memory inside the unit is capable of far higher speeds. Because of this backing up the device and installing things to it takes 1 hour (500 KB/s) instead of 4 minutes (10 MB/s). My little USB thumb drive (Super Talent Pico) can transfer files at roughly 20-25 MB/s and that has no CPU inside it to speak of. Just a memory controller that costs no more than a few 10s of cents to actually include in a product for any manufacturer who is ordering 10000 of them.
 
Oh, I forgot to mention. I managed to download and install the maps without corrupting them on the way. I think someone must have seen the 10 anonymous error reports that were sent off and fixed something on their servers.

Thanks for your help guys!

Now all I need to be truly happy is a good Arnold Schwarzenegger voice for my TomTom.

"GET OFF DE HIGHVAY!"
 
In regard to the original title of my post. After finding out that the device is actually USB 1.1 I think I have to revise my statement that the hardware is "great". Seeing that USB 1.1 was released in 1998 and USB 2.0 is from 2000 the fact that a device released in 2009 has such old tech in it is kind of horrifying.

Yep, its seems when you buy the cheaper model of anything there are compromises. It would be nice to live in a world where the ONLY difference between a more expensive model and a less expensive model was the price. Unfortunately I'm restricted to this world...reality....where more expensive = better, less expensive = worse....

heheh j/k. However in tomtom defense its obviously a way to save on cost and pass that on to the consumer. AND as long as everything is operating properly there is only the MAX of 4 large downloads (maps) per year. Unlike your Cowon which probably sees a lot more data transfer...
 
Last edited:

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

No members online now.

Latest resources

Forum statistics

Threads
29,149
Messages
197,087
Members
68,204
Latest member
jovigom

Latest Threads

Back
Top