TomTom HOME V 2.1.2.121 Won't run on XP Professional?

Discussion in 'TomTom Home and MyTomTom Software' started by Michael J, Dec 15, 2007.

  1. Michael J

    Michael J

    Joined:
    Dec 15, 2007
    Messages:
    13
    Likes Received:
    0
    Has anyone had trouble with TomTom HOME V 2.0 or 2.1.2.121 not running at all on Windows XP

    Professional SP2?

    When I start the program, I see the TomTom HOME 2.1 splash screen. Then about 30 seconds later I

    see an error dialog box:

    "xulrunner.exe has encountered a problem and needs to close. We are sorry for the

    inconvenience."

    It offers the opportunity to either "Debug", "Send a report to MicroSquash", or "Close".

    If I select any of the choices, it closes itself and the splash screen (program).

    If I were to just let the box sit there for a bit, the program will start (Behind the box). If I

    chose to close the box, it will close the program as well (this will happen for any choice in the

    dialog box).

    If I were to drag the box to the side, and try to use the program, it all seems to work (as long

    as I don't close the error dialog box).

    Is it TomTom HOME or XP Pro?:cool:
     
    Michael J, Dec 15, 2007
    #1
    1. Advertisements

  2. Michael J

    sparky672

    Joined:
    Nov 25, 2007
    Messages:
    286
    Likes Received:
    11
    Location:
    Chicagoland
    TomTom Model(s):
    ONE 3rd Edition
    sparky672, Dec 15, 2007
    #2
    1. Advertisements

  3. Michael J

    greal

    Joined:
    Dec 9, 2007
    Messages:
    82
    Likes Received:
    3
    Michael,

    Are you running Firefox/Thunderbird/any Mozilla-base application at the same time? TT Home and those apps share a lot of mechanisms/code, and although they're supposed to be insulated from one another (they have their specific settings in different profiles), sometimes it just isn't so. What I'd suggest:

    a) exit any XUL-based application you might've launched before TT Home (and make sure they're really gone - check in your Task Manager that they're not leaving a ghost in your system's memory);
    b) should this yield no results, it may be that the config files are not being read correctly - this may happen when you have a minor file system problem. Run chkdsk on the drive where TT Home is keeping his profile (usually C:, but not always; for example, my Documents and settings are on a different drive (D:) and, while the app has installed under C:\Program files, its settings are on D: (under Documents and settings\%%\Application Data\TomTom\)
     
    greal, Dec 15, 2007
    #3
  4. Michael J

    Wiley

    Joined:
    Jun 3, 2007
    Messages:
    157
    Likes Received:
    17
    Location:
    Oregon, USA
    Locate xulrunner.exe and run it by itself...

    The first thing you need to do, is to establish if xulrunner.exe will actually execute on your PC. Here is where it is located on my XP SP2 computer: C:\Program Files\TomTom HOME 2\xulrunner\xulrunner.exe. NOTE: I use Firefox (by Mozilla) as my primary browser. It too uses xulrunner...but without any conflict.

    If it fails, boot XP into safe mode, and try it again.

    If it works in safe mode, it is likely that something else that runs in XP's normal mode, is causing a problem. About the only way to figure that one out is to use XP Task Manager to identify the running apps, then systematically stop each one and try to run xulrunner.exe. Additionally, you might want to run "services.msc" from a command-line prompt. From there, you can temporarily stop and disable running services as you check if xulrunner.exe will execute. BE CAREFUL HERE... DON'T KILL ANYTHING PERMANENTLY, UNLESS YOU UNDERSTAND WHAT THE CONSEQUENCES WILL BE. PLAY IT SAFE WITH SERVICES AND THE REGISTRY IF YOU ARE NOT AWARE OF THE POTENTIAL DAMAGE YOU CAN CAUSE.

    If xulrunner.exe runs as it should, you will be presented with a dialog that references the possible parameters you can append. The fact that you can see the dialog at all implies that xulrunner.exe is likely not the cause of the error you are experiencing.

    If xulrunner.exe seems to be running on its own, It's likely that some other part of the Home installation is broken and you might as well uninstall, clean up any residual bits and pieces of Home on your drive, and in the registry...then reinstall from "ground zero."

    If all else fails, and before you talk to TomTom, you can try doing a Google on "xulrunner.exe". TomTom uses the app, they didn't create it, they don't own it. You should find a number of troubleshooting tips available for other applications that use xulrunner. Good luck.
     
    Last edited: Dec 15, 2007
    Wiley, Dec 15, 2007
    #4
  5. Michael J

    Michael J

    Joined:
    Dec 15, 2007
    Messages:
    13
    Likes Received:
    0
    Locate xulrunner.exe and run it by itself...

    Thanks for the help Wiley!

    I tried running xulrunner.exe independantly, and got the same result.

    Then I tried running it in safe mode...no joy there either.

    I didn't bother to try the re-install as I have already done that a few times anyway.

    I ran "Services.msc" and tried disabling a bunch of stuff, I will return to that again later.

    I then remembered I have a copy of xp pro installed on another hard drive, so I shut down, swapped the HDD and booted up. I then installed TomTom HOME and gave it a try.

    Voila! it works!

    Apparently the problem lies with my current install of XP Pro.

    Before I shut down, I printed out (in .csv format) the contents of the Services.msc directory. I will do the same with my current XP pro version and compare notes.

    It must surley have been a case of me tweaking things and either inadvertantly turned off something, blocked something or what ever.

    now all I need to do is identify what it is and rectify the situation.
    :cool:
     
    Michael J, Dec 15, 2007
    #5
  6. Michael J

    Michael J

    Joined:
    Dec 15, 2007
    Messages:
    13
    Likes Received:
    0
    TomTom HOME won't run on XP Pro

    Well, basically I've determined that it is not TomTom HOME that is the problem, but I for the life of me can't figure out what might be stopping xulrunner from starting up?

    Anybody?
     
    Michael J, Dec 16, 2007
    #6
  7. Michael J

    Wiley

    Joined:
    Jun 3, 2007
    Messages:
    157
    Likes Received:
    17
    Location:
    Oregon, USA
    An experiment... Try installing the Firefox browser.

    Well, you might as well try attacking the problem by doing an end-around. Try running Firefox and see if you get the problem. Firefox makes BIG TIME use of the components that service xulrunner.exe NOTE: You won't see specific references to "xulrunner.exe" if Firefox encounters a problem. However, you may see error messages that implicate "XUL" or "xul".

    If you do get errors when you run Firefox, you will have access to a wealth of debugging resources that will help you pinpoint where the problem is. It is VERY likely that fixing Firefox will also fix the issue with TT Home. Once you get xulrunner going, you can choose to totally remove Firefox. Frankly, I bet you won't want to though. But that's a whole other topic. :rolleyes:

    FYI... Firefox lives happily next to IE.

    Here is the unofficial/official forum for all things Mozilla...and Firefox: http://en-us.start.mozilla.com/firefox

    Get Firefox here: http://www.mozilla.com/en-US/firefo...07lndgpgtest&gclid=CJyVo_ivrZACFSFaagodHl_j8w
     
    Last edited: Dec 16, 2007
    Wiley, Dec 16, 2007
    #7
  8. Michael J

    Michael J

    Joined:
    Dec 15, 2007
    Messages:
    13
    Likes Received:
    0
    Tried Firefox and.....

    Well, I already have Firefox on my system, and I must say it's been sweet for a while now.

    I tried un-installing it, and heck, while I was at it, I upgraded it. It's running fine! No hiccups at all, it's just that the xulrunner supplied with tomtom doesn't like my PC for some strange reason.

    I'll follow the links you gave me, and hope I can find some relief.

    In the mean time, if anyone can think of something else to try, I'm all ears!
     
    Michael J, Dec 16, 2007
    #8
  9. Michael J

    Michael J

    Joined:
    Dec 15, 2007
    Messages:
    13
    Likes Received:
    0
    Solution found!

    I had a problem with xulrunner on my XP pro machine. I found the solution, it was AVG anti virus! I un-installed it, cleaned out any references to TomTom in the registry,and made sure all the programs running in the task bar were shut down, re-installed TomTom HOME 2 and voila! it works now.:D
     
    Michael J, Jan 6, 2008
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.