TomTom Home on Windows 7 64bit

Discussion in 'TomTom Home and MyTomTom Software' started by dhcfi2, Jul 7, 2010.

  1. dhcfi2

    dhcfi2

    Joined:
    Jul 7, 2010
    Messages:
    1
    Likes Received:
    0
    Location:
    Tucson AZ
    TomTom Model(s):
    XL340S
    I have a new xl-340S. I love it. However when I downloaded Tomtom Home ver 2.7 and installed it on my 64bit windows 7 professional laptop, it installed successfully. When I try to run the program, I get the following error: ERROR: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIProperties.get]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://tthome/content/logic/settings.js :: anonymous :: line 283" data: no]
    in chrome://tthome/content/logic/settings.js:283
    Stack:
    0. chrome://tthome/content/logic/settings.js:283
    this._dataDir = directoryService.get("Pers", CI.nsIFile);
    1. chrome://tthome/content/logic/settings.js:258
    this._initAppDirectories();
    2. chrome://tthome/content/logic/app.js:39
    this.settings.start();
    3. chrome://tthome/content/ui/mainwin/mainWin.js:45
    gApplication.start();
    4. function onLoad chrome://tthome/content/ui/mainwin/mainWin.js:15
    gMainWindow.start();
    5. function onload chrome://tthome/content/ui/mainwin/mainWin.xul:1
    <?xml version="1.0"?>

    Time: Wed, 07 Jul 2010 21:29:51 GMT

    I have turned off all firewall and anti virus applications and reinstalled it to the same error.

    Tom Tom support says go to the library and use a 32 bit PC. Their support is unbelievably poor.

    Can anyone help me, PLEASE?
     
    dhcfi2, Jul 7, 2010
    #1
    1. Advertisements

  2. dhcfi2

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    23,026
    Likes Received:
    446
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    Some find running Home as XP compatible mode helps............
     
    dhn, Jul 8, 2010
    #2
    1. Advertisements

  3. dhcfi2

    CJT46

    Joined:
    Jul 13, 2010
    Messages:
    1
    Likes Received:
    0
    TomTom HOME isn't ready for 64-bit Windows 7

    A few weeks ago, I foolishly decided to upgrade my TomTom with the latest maps. What a mistake! I paid, downloaded the latest version of HOME and tried to install it to my device via USB. The progress bar inched across the screen...and the stopped just short of the end. An error was being reported writing a particular named file (call it "blot" because I can't recall it exactly) to the device. So the saga began. I tried everything I couls think of: always the same error, same file ("blot") .

    Customer suport were helpful - call ed the device in for checking (it wasfault-free)but I still had a device which wouldn,t install maps OR load backups. Finally I thought blow this for a game od soldiers, and repeated the whole process on a borrowed Windows XP machine. Result: happiness. Told Costomer Support this and their response was that I must have been the victim of an unlucky coincidence.

    So, it seems as if you have the following options, depending on your technical background and patience:

    1: go to the library and use WINXP
    or 2: run HOME in XP compatibility mode on your own machine (I didn't try that)
    or 3: if you have hardware assisted virtualisation on your W7 machine then try downloading Windows Virtual PC and then runing HOME within it.
    or 4: get your money back for the TomTom and buy a (e.g.)Garmin!

    Good luck
    Chris
     
    CJT46, Jul 13, 2010
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.