Tomtom Home for Navigator 7


mir

Joined
Dec 12, 2007
Messages
5
Location
Sweden - Sundsvall
TomTom Model(s)
One 3rd generation
Hope someone can help me? Trying to connect my Sony Ericsson X1 with Tomtom 7.915 fo Tomtom Home. TT Home can not find the device? No matter if I run Active sync or memory location.

Anybody got tips?
 
Ad

Advertisements

mvl

Moderator
Joined
Dec 19, 2008
Messages
5,458
Location
Boston, MA, USA
TomTom Model(s)
GO 2535 LIVE, GO 1535 LIVE, GO 740 LIVE, Go 930
Did you try downloading HOME from the Tomtom website? Others have posted that the version on the Tomtom website is newer than the version that HOME currently auto-upgrades to on its own.

The windows version on Tomtom's website says it's compatible with navigator 7.

Please post back if it does/doesn't work for the benefit of others.
 
Joined
Jul 5, 2009
Messages
1
Me too. I've downloaded the latest TTHome (2.6.4.1641) and it does not recognise my PDA.

Picks it up using TTHome 1.5, but there is no MapShare. When I revert back to Navigator 6 TTHome 1.5 also picks it up but not 2.6

I've tried everything I can think of and seen on discussions including putting Home_Image files on the root directory.

Some thoughts. Is it because it's not on the list of recognised PDAs? Can we change the registry to make it think it is from the list?

Cheers...
 
Joined
Jul 8, 2009
Messages
2
Yeah i'm having the same troubles.
TomTom2 work with Navigator 7. Well its says it is compatible on the UK ver.
But when i looked at the US Ver. it didn't say it worked.

So if anyone has an idea on how to make it work it would be great.

I have a HTC Touch Pro.
 
Ad

Advertisements

Joined
Aug 2, 2009
Messages
1
How did you even get it installed on the Sony X1? I just purchased TomTom 7.9 with maps of Western Europe and it won't even install. It says the device is not compatible, and yet I have seen several reports of people running it and have even seen a YouTube video of it working.

Thanks
 
Joined
Aug 4, 2009
Messages
2
TomTom NAVIGATOR NAVIGATOR 5, 6 & 7 Discussion

Same problem here with tom tom v7 trying to sync with a touch pro 2 even though it worked on my previous touch pro any ideas please?
 
Joined
Aug 6, 2009
Messages
1
me too I`m using an O2 XDA Zest and I have Nav 7 installed. 1.5 TomTom Home sees it fine but 2.6 refuses to. Even tried the new BETA 2.7 and thats the same.

Tried the SD card method and 1.5 sees it but still 2.6 does not.

Strange.
 
Ad

Advertisements

Joined
Aug 22, 2009
Messages
2
I couldn't get my Touch Pro to connect at first either. I'm not sure what version I had initially, but here's what worked for me:

1) Uninstall Navigator 7 and maps.
2) Delete all Navigator folders and files
3) Download and install Navigator 7.450.9028 (I know it's an old version, but it worked). You can get it here.
4) Connect the device without TomTom Home running, wait until ActiveSync is connected.
5) Start TomTom Home. It will probably tell you you need to update the device. Go through those steps.

Now it's connecting just fine for me. My problem now is that I can't buy any maps or download Map Share corrections, but I'll make a separate thread about that.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top