TomTom Go 950Live low framerates


Joined
Jun 5, 2010
Messages
3
Hi, I've bought a TomTom Go 950Live today, but the framerate is just awful! I mean, only 1, 2 FPS at best!
I had a 920 for a few months about 2 years ago, and the framerate was ok (now awesome, but OK, like 4 fps).
Other navigation software like Ndrive and Igo have far more better framerate (around 10fps).
I think this is crucial, because with this framerate, I miss a lot of exits and entries (especially in Portugal, where the streets are narrow and almost next to each-other.
I don't know why no review talks about the TomTom framerate. I think this is a crucial issue that TomTom must resolve. This is not a hardware bottleneck, because other developers get far better framerates with lower hardware specifications (and with better graphics, more AA for instance).
And what about your TomTom, does it also have a lousy framerate in navigation?
Kind Regards.
 
Ad

Advertisements

Joined
Mar 23, 2009
Messages
3,199
Location
Blackpool UK
TomTom Model(s)
720, 930, 940, XL, One 3rd
How many POI files have you got selected to show while the navigation screen is displayed as this is usually what slows the refresh rate down to a crawl - Mike
 
Joined
Jun 5, 2010
Messages
3
How many POI files have you got selected to show while the navigation screen is displayed as this is usually what slows the refresh rate down to a crawl - Mike
Hi Mike, first let me thank you for your fast answer.
I've no POI selected to show while in navigation, and even with no POI's selected, as I said before, the framerate is about 1 FPS average, 2 FPS max. It can reach 3 FPS out of town when there is just a road ahead. But at least for me, this is unacceptable. I mean, navcore 6 had a far more better framerate.
TomTom 950 has some awesome live features (HD traffic, Google Search, weather and so on), but it fails where it should, in navigation.
Can you please tell me what's the average framerate of your TomTom PNA (if you have one please specify the model and Navcore version).
Kind Regards.
 
Ad

Advertisements

Joined
Mar 23, 2009
Messages
3,199
Location
Blackpool UK
TomTom Model(s)
720, 930, 940, XL, One 3rd
I would say my 950 is running at between 5 or 6 frames per second, I can't list the Navcore currently loaded as its something you might get at a future update.

I can't remember the 950 running any slower than this with any previous Navcore installed other than after loading lots of custom POI files and the stupid thing automatically enables them to display on the Nav screen, you have to go in and de-select them all, if you have installed custom POI files its worth checking that they are indeed de-selected to ensure they don't show on the screen as these really hammer the processor which in turn slows the screen refresh rate - Mike
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top