TomTom Go 600 stuck during update

Discussion in 'Technical Support' started by Ian, Sep 21, 2018.

  1. Ian

    Ian Administrator

    Joined:
    Oct 30, 2011
    Messages:
    475
    Likes Received:
    3
    I've got a TomTom GO 600, which is currently unusable and I wondered if people here may have any suggestions.

    A couple of weeks ago, I plugged the device in to my PC and used TT MyDrive Connect to update the NAV4 software, maps and speed camera database. The software and speed camera update went fine, but during the installation of the maps the sync managed to remove all maps and languages, leaving me with a dead unit. Resets and software restores didn't do anything - but TomTom were happy to do an out-of-warranty repair to re-flash the unit back to stock.

    It arrived back (working!) a couple of days ago, but when I tried to update the maps and software, I get similar problems again (although language packs are installed this time). During the Europe + UK Building map update, it deletes the old map from the device but is unable to copy over the new map back to the TomTom. The MyDrive Connect software starts to update, but after 30 mins or so of the percentage bar increasing, it zips to "0%" and the TomTom GO 600 just asks me to wait for the update to resume.

    I've left my PC on overnight twice, but it doesn't budge:

    Capture.PNG

    If I remove the USB cable and try again, it does the same thing again and again.

    I've tried all of the following:
    • Restarted PC
    • Disabled Anti-Virus
    • Different USB cable
    • Different PC
    • Full MyDrive uninstall, clear %appdata% and then a fresh install
    • Drum reset of TT unit
    • TT software restore
    • Factory reset
    As the unit is out of warranty, I have few options. I've got a ticket in with TT support, but as they've already re-flashed it once I don't know what else they will do.

    Any thoughts on what else I can try?
     
    Last edited: Sep 21, 2018
    Ian, Sep 21, 2018
    #1
    1. Advertisements

  2. Ian

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    22,793
    Likes Received:
    420
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    But if you paid to have the device getting reflashed, is there not some warranty on that work? You are meaning MyDriveConnect, not MyDrive, correct? (two different animals)

    Have you tried the Recovery Process, Ian? See here:

    http://uk.support.tomtom.com/app/answers/detail/a_id/1898
     
    dhn, Sep 21, 2018
    #2
    1. Advertisements

  3. Ian

    Ian Administrator

    Joined:
    Oct 30, 2011
    Messages:
    475
    Likes Received:
    3
    Yes, sorry it was MyDrive Connect - I've corrected the first post now.

    It was a free out out warranty repair (with some wrangling) as it happened during a software update - it may be that they'd offer to do it again, but I suspect I'll have the same problem as soon as I try a software update.

    I've tried that recovery process a few times, but I end up back in the same loop as soon as I reconnect the TomTom to my PC.
     
    Ian, Sep 21, 2018
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.