TOM TOM XL Classic


Joined
Aug 29, 2012
Messages
3
Location
UK
TomTom Model(s)
XL Classic
Not having used it for some time, I connected it to charge it up. Intially it worked but now it is locked and will not power down.

The screen now has an oval coloured background with a number of vertical lines. Any suggestions please ?
 

Attachments

Ad

Advertisements

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,146
Location
Toronto Canada
TomTom Model(s)
1535 LIVE; Via 1605; Go 50; Go 520
Try resetting the device by holding the power button about 15 seconds till you hear the drum sounds unless your model has a dedicated reset hole.
 
Joined
Feb 11, 2011
Messages
4,683
Location
London, UK.
TomTom Model(s)
Go520,720,XL Live, Start60,Go940,950,1000,1005,New500,New5000
Euwgh!

Afraid that looks like a hardware problem to me (I hope I'm wrong!)

Any possibility it got dropped or squashed on the screen?
 
Joined
Aug 29, 2012
Messages
3
Location
UK
TomTom Model(s)
XL Classic
No it has been in my room unused. Resetting doesnt work either. Is this the TomTom variant of the Blue Screen of death ?
 

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,146
Location
Toronto Canada
TomTom Model(s)
1535 LIVE; Via 1605; Go 50; Go 520
Ad

Advertisements

Joined
Aug 29, 2012
Messages
3
Location
UK
TomTom Model(s)
XL Classic
Thankyou for that info, at the moment it is working after shutting down. The internal battery is totally flat so I am monitoring it before going down the backup route.

BTW I am most impressed by the speedy help, thankyou very much
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top