Tom Tom One won't power on


Joined
Nov 1, 2009
Messages
1
My TomTom One (3rd edition) will not power on unless it is connected to my PC via USB. After being plugged in for just a short while, it WILL turn on if unplugged. It also seems to "forget" the update that I added to it using the Tom Tom online updater software.
Any ideas how to proceed?
This thing worked brilliantly back in August and September, and now for no reason, it is acting up after being left unused for a few weeks. :confused:
 
Ad

Advertisements

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,156
Location
Toronto Canada
TomTom Model(s)
1535 LIVE; Via 1605; Go 50; Go 520
Have you tried a reset on the unit?

Also, try the Clear Flash tool found here.

Run it 3 times.

Further, have you fully charged the unit with the car charger? If it is not holding the charge, the battery may be dying.

Try the reset and clear flash first.
 
Ad

Advertisements

Joined
Jan 18, 2020
Messages
1
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
GO5100
I couldn't power on my GO5100 by usual method of pressing OM button for 5 seconds.
Like some phones that you need to disconnect the battery to get them going again, that's what I did with the GO5100.
Follow online instructions to remove the back plate and connectors, then remove battery connection for a couple of minutes. If you can test the battery for power that would discount a dead battery. If you get a reading of 4 volts then there's a good chance it's OK. Reconect battery lead and replace backplate, not forgetting to reconnect any other leads. Try that. Good luck.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top