Tom Tom One Freezes on Route Planning Screen. Help Please

Joined
Jun 19, 2010
Messages
6
Hi There,

I hope someone here can give me a hand. I've owned a TomTom One 3rd edition for about a year now and it's worked great. Up until now. Here's the issue: the device boots up normally and everything looks to be running great, right up until you try to navigate somewhere. You can enter an address and from this point the nightmare begins. The device freezes on the route planning screen, ie. when you need to choose between fastest route, quickest route etc.

I have backed up and reinstalled software, run the clear flash tool, reset, reinstalled from tomtom home and bashed my head against my keyboard in exasperation. All to no avail. If anyone has any suggestions, please let me know. It'll be greatly appreciated because I can't find my way out of a cardboard box without my tomtom.
 
Welcome to TTF.

Make an Explorer, not Home, backup of your unit's contents. Then format your unit but don't use quickformat.

Restore the backup using Explorer again. See if that helps.
 
Thanks - anymore suggestions?

Wow, that was a quick response, I should have mentioned in my original post that I have tried the explorer back up and restore trick, I still get the same issue. Is there perhaps a way to completely reinstall the entire operating system? I have tried deleting everything bar my maps and then reinstalling from TT home - i still get the same problem, but I have noticed that my name, etc is still on the device, so I'm assuming there is a deeper level of memory which may be corrupt. Is there a method of accessing it? I have been trawling this site to see if anyone has had this exact same problem but so far, nothing.

I'm assuming that the touch screen is working properly as I can still use it before I get to this point. I doubt the warranty is still in effect as I purchased the device in Jan 2009.

Any help you could provide will be greatly appreciated.

Thanks
 
You can try the clear flash tool found here:
tomtom.com/6211

Run it 3 times.

If that doesn't help, do the format as I suggested.
 
unfortunately, I've tried everything you have suggested, and a couple of other suggestions I have found elsewhere. Still nothing.
 
You may have tried this but do it once more.......

Use Explorer to delete all the loose files in the root of the unit. NO folders or their contents. Connect to Home. It'll offer an application. Accept and install it.
 
Tried that again, it looks like the device is properly broken, I spose I'll try take it in for repairs, thanks for all of your help
 
Wow, that was a quick response, I should have mentioned in my original post that I have tried the explorer back up and restore trick,

DHN recommended:
- backup
- format the device with quickformat disabled
- restore

Did you do the format step?
 
Regarding unnamed streets in tomtom

Hi everybody!!..

I have a tomtom start2. In that it shows certain streets as unnamed in fact most of the streets. The samething happens even when i use the latest version map of 850.___.

So can any one help me out??


Raja
 
Hi everybody!!..

I have a tomtom start2. In that it shows certain streets as unnamed in fact most of the streets. The samething happens even when i use the latest version map of 850.___.

So can any one help me out??


Raja

I copied your post to a separate thread since the topic was different enough from this discussion. See here.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
29,137
Messages
196,964
Members
68,183
Latest member
silkroad

Latest Threads

Back
Top