Stupid 6 month device registration problem

Discussion in 'Technical Support' started by Piggie, Jul 5, 2009.

  1. Piggie

    Piggie

    Joined:
    Jul 5, 2009
    Messages:
    23
    Likes Received:
    0
    I've had my original TomTom Classic for years now and never let me down.

    Recently I installed a new version of windows on my PC and didn't bother installing any TomTom software as for me my TomTom just does what I need and I don't want to upgrade stuff much.

    Anyway, I saw a guy selling his TomTom 720 model and I bought it from him. When I got it, I installed the TomTom software on my PC and did some updates (as was my new toy so to speak) and registered the device against my account.

    The following day I was going to charge it and after much testing I found out it suffers from the Seemingly common problem of the stupid design of the USB port on the bottom of the device not making a reliable connection, so I had to press the connector back to make it charge (in normal operation on a car mount the wire would be hanging down and it would not be charging)

    Also on the desk mount the connection was hit and miss and it would go on and off charge every 10 seconds or so, (again, something I've read about others experiencing)

    I cleaned the contacts but make no difference, so contacted the guy saying he's sold me something that's obviously faulty (it was advertized as being in excellent condition) and he has offered me a refund.

    Which is great and very honest of him, but I'm a bit dissapointed it's not right and also dissapointed in the stupid design which apparenty is causing mnay others the same problems.

    Anyway, with this out of the way, and the TomTom software still on my PC. I thought I may as well plug my old TomTom which I will go back to using in, and register my old device back to my account (as I'm sending the 720 back to the guy)

    But, no, I can't do this, as (for some utterly stupid reason) I can't change the decide registered to my account for another 6 months time !!!!!

    How totally idiotic is this?

    So, unless I make another account with a different email address I can't use the software with my original TomTom for 6 months, just cos I used the other 720 model for one day.

    Fan, Bloody, Tastic !!!

    :(
     
    Piggie, Jul 5, 2009
    #1
    1. Advertisements

  2. Piggie

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    23,135
    Likes Received:
    450
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    Try calling UK support on Monday to see if you can get this all sorted out.

    Btw, I'm not sure what forums you're hanging out, but a problem with a TT 720 not making a proper docking connection is NOT something many are reporting in the forums I view........
     
    dhn, Jul 5, 2009
    #2
    1. Advertisements

  3. Piggie

    mikealder Moderator

    Joined:
    Mar 23, 2009
    Messages:
    3,199
    Likes Received:
    45
    Location:
    Blackpool UK
    TomTom Model(s):
    720, 930, 940, XL, One 3rd
    Each device should have its own unique account to save the issue you are now finding, having multiple devices attached to a single e-mail account is not a good idea as the Home software and TT Server gets in a real pickle.
    Just create a new account for your old device with a different e-mail address (it doesn't need to be a true working e-mail address though, just make sure its in the e-mail format) - For example "[email protected]" would be fine as far as TT Home is concerned even if the e-mail account cannot receive/ send e-mail.
    With each device having its own account your TT Home software will handle which unit is connected, I have around ten different devices associated with my home PC, no problems as each device has its own e-mail address, non of them are using my actual e-mail account though! - Mike
     
    mikealder, Jul 5, 2009
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.