QuickGPSfix data

Jul 24, 2010
Ronkonkoma NY
TomTom Model(s)
XL 335 S, Via 1535TM
I have an XL 335. TT Home Update used to offer a new download for QuickGPSFix almost every day. Now it has not offered to update QuickGPSFix for over a week? Anyone know what is going on here?


Not sure this is the reason, but...........

Sometimes a faulty file clogs up the 'pipeline' on a computer and prevents further files being sent.

So, try this:
1. Use Explorer to delete everything in the ephem folder on your unit

2. Go here:
c:\documents and settings\yourname\my documents\TomTom\Home\Downloads\Complete\ephemeris\

and delete any sub-folders you see in there.

Now, connect to Home and you should be offered a new file........
I've also noticed that TT Manage My Device is not listing and GPS fixes, for "items ond evice," although I have some backed up, and listed, for "items on computer."
I've also noticed that i don't have an lto.dat file in the ephem folder, only ee_meta.tlv, and ee_meta.txt. Also, in the *.cab file saved in "C:\Documents and Settings\Ted\My Documents\TomTom\HOME\Download\complete\ephemeris\QuickGPSfix-7" there is only an ee_meta.txt and lto.dat, no ee_meta.tlv. And I have no idea what the different files are for. But I've noticed that lto.dat is by far the largest. Also, the files in the cab file have "last modified" dates of 2102-06-04. That is, year 2102, month jun, day 4!
I don't understand why it would make any difference what I have in my C:\Documents and Settings\[name]\My Documents\TomTom\HOME\Download\complete\ephemeris\ folder or why you are asking me to delete everything in there.
but I followed your instructions and I am still having the problem. Maybe I should dry deleting the application program and downloading a new one?


I also have a copy and paste backup that I made of the ephem folder, about a week ago.

I wonder if having Tripmaster on my TT is causing the problem.
I wonder if the fact that TT Manage My Device is no longer listing "QuickGPSfix data," under "items on device," is a clue to what is going on.
Okay.......(Tripmaster shouldn't matter at all)............

1. Remember your user email address/password for your unit's account at TomTom. You'll need to enter it manually after the following processes.......

1. Download Revo Uninstaller from here (free version):
Revo Uninstaller - Free software downloads and software reviews - CNET Download.com

2, Completely uninstall TomTom home from your unit.

3. Download and install the latest Home version from here:
How do I install TomTom HOME?

4. Connect your unit to Home & manually enter your log in name and password.

See if you get the file now.
Well, I removed tripmaster (just cut and pasted files to a folder on my computer, so I can easily put them back again). Then I found my most recent backup of my whole TT flash drive, and copied the 3 files that were in the backup of /ephem, to ephem on the TT. After about 1/2 hour, I got a prompt from TT Home Update, to update QuickFix. And now this QuickFix is appearing on "device" when I look at TT Home Manage my Device. So I guess the problem is solved, for now. I'm not sure which action solved the problem, reloading application, copying the missing lto.dat file along with other QuickFix files of the same download date, or removing TripMaster. I suspect it was that missing lto.dat file, that was needed to tell TT Home when it is time to download a new version of QuickFix.


I'm not sure why I bothered with all this, as TT doesn't seem (I haven't taken any actual time measurements) to lock onto satellites any faster, or replan routes any faster, with the latest GPS fix data. It always seemd to do these fairly fast, even w/o the lastest data. But, what the heck.
If the truth be known, many who use their units on a regular basis never download the gps file and their units work just fine.
I'm still confused as to why the backups on the computer (cab file or zip file), shown with TT Homes "Manage your device," don't contain and ee_meta.tlv file, just an ee_meta.txt file, and lto.data file. I'm guessing this the emphemeris.toc file in addition to the cab or zip file, is simply so that TT Home "Manage my device," knows how to list the cab or zip file, and nothing from it is needed in the TT ephemeris folder.
dhn " the truth be known, many who use their units on a regular basis never download the gps file and their units work just fine."

Hee hee. I'm not surprised.
Can someone tell me what the ee_meta.tlv file is for, and why it doesn't get saved when you do a backup with TT Home "Manage your Device"? TT Home automatically backs up QuickGPSfix to a cab file. And you can manually choose to do a "copy to your computer" of QuickGPSfix to - in which case the backup goes into a zip file. In either case, only the *.dat file and the *.txt file, from the TT /ephem folder get backed up, not the *.tlv file.

Nuts, I thought my GPSfix update problem was solved, when TT Home offered to do an update again, for the second time, since I restored my missing lto.dat file to the ephem folder. But looking at the latest lto.dat file, i see that it is 0kb, instead of the usual 60 to 79 kbs. What's going on here?


The automatic backup into the ephemeris.cab file, also shows an ephemeris.cab file - of only 1 kb. Opening the archive shows that the backed up lto.dat file is 0 kb.
Weirder still, although the actual lto.dat file on the TT flash drive has 0 kb, and the backup in the cab file on my computer has 0 kb, TT Home "manage your device" "items on computer" page lists the backup as having 60 kb.
Alright, TT Home is getting the mistaken filesize data, from the ephemeris.toc file, rather than the actual cab file or lto.dat file, so that explains the mistaken size, although why there is a wrong table of contents file, I don't know. But this is getting rather confusing.


OK, I removed some of the newer GPSfix items on "my computer," in the "download\complete\ephemeris" folder - I hadn't realized that TT Home downloads to "my computer" first, then extracts to "my device." So deleting from TT at T:\ephem and replacing with uncorrupted files, wasn't enough. Extracted "new newer" ephem files from cab file to t:\ephem, then close TT Home, restarted, disconnected TT, then reconnected, then updated, and got an lto.dat file in the ephem folder that has actual contents.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads