newbie - 2nd TT-same orange screen


Joined
Feb 21, 2009
Messages
4
worked fine, until I plugged it into our Mac 10.4 to update maps.
went through required steps.
now, the screen is white banded orange with a dark graphic of the plugged in TT and it will not respond when the screen is pressed.
Early posts said to press the button to re set the tt. I have.
other than that - no clue.
by the time I get home, the support phone ? is busy / or they all have gone home.

thank you, in advance, for easy to understand solutions ...I am not a teckie

shalom !
Coline, Manitoba, Canada
 
Ad

Advertisements

Joined
Feb 21, 2009
Messages
4
please advise - TT One screen is still orange - no maps

I plugged it into our Mac OSX 10.4 all night, hoping to charge it.

I re-installed " Home."

My 91 year old Mum & I are taking a road trip to the US this Thursday. Navigation is not a strength - that is why my husband bought this for me !

many thanks, in advance

Coline
 
Ad

Advertisements

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,273
Location
Toronto Canada
TomTom Model(s)
Go 50; Go 520
Perhaps the Clear flash tool found here may assist. I'm inclined to think that a call to support at 866-486-6866 is necessary.

They're open 8:30 am to 7 pm Eastern time so perhaps you can find a window of opportunity to call them.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads

Another newbie to be tolerated. 0
Motorcycle GPS Newbie 1
Greetings from a newbie !! 3
Newbie 5
newbie saying hello 2
Newbie getting "Knotted" routes 7
Newbie to site and tomtom's 1
2nd Newbie Question 2

Top