My Routes has disappeared on the TomTom Go App

Joined
Jun 21, 2024
Messages
11
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
Rider 550
Afternoon All,

I've recently created 12 routes, all safely stored on MyDrive for a motorcycle tour (next week). They all sync'ed to my Rider 550, no issues. Then I discovered the Carpuride W702, a car play like device.
As the 550 screen is quite small, the W702 appealed to my doggy old eyes. I bought one, wired it in and loved it. Running TomTom Go from my Iphone 13.
It does tend to eat data and drain my battery though, so I borrowed old 2020 Iphone SE, bought a cheap £5 a month sim card with 30GB of data and mounted the phone on a wireless charging Quad lock.
All sorted, my own phone safe in my pocket, the SE on the bars running the Go app on the screen. Perfect display, working set up. However, when I went to pick a route for a test ride, My Routes on the Go app is empty, No saved Files.
My places is full of all my places, recent destination is full of my own data to, so where are My Routes :-(

With only a week to go, this is driving me bonkers. I logged out of the Go App, logging back in makes no difference. I logged out of My drive, logging back in makes no difference. I've created a new route, synced to 550, no issues, but its not appearing on the Go App.
Then the final disaster, I logged out of the Go App on my iphone 13, logged back in and the My Routes that were all there, have now disappeared too. So now neither phone has any of My Routes and im all out of ideas.

Any suggestions, is it a setting I'm missing ?
One person suggested My drive routes are not supported on the Go App, they worked perfectly on my Iphone 13 the week before last, when we had a few days riding around Northumberland, some of those routes had been on My Drive for 3 years or more.

Help!!!


thank you

Pete
 

Attachments

  • TomTom Go App.png
    TomTom Go App.png
    578.9 KB · Views: 17
In my opinion, it's because you are not logged in with the correct credentials for your Tomtom account.
Reset the device to factory settings, then enter your email address and the correct password.
 
In my opinion, it's because you are not logged in with the correct credentials for your Tomtom account.
Reset the device to factory settings, then enter your email address and the correct password.
I've currently delted the Go App from my phone so once im home nad I re load it. I will ensure that both of my Id's are exactly the same passwords etc. Hope your right.

Pete
 
The same login ID on the Tomtom GO application is on Mydrive.
The same login ID on the Tomtom GO application is on Mydrive.

Sadly that doesn’t work as both ID’s are identical on each app. MyDrive and Tomtom Go both have the same password and as i suspected, always have had.
Also of note, “my places” is fully populated as is “recent destinations”. So it had 2/3rds of my data. Flippin frustrating 😫
 
One question is 12 routes you have created can you read them on your rider 550?
 
In settings on the GO app make sure you turned on syncing, then close the app and re-open
 
Last edited:
It is already on. Have tried it off, log out, log in, back on, log off, log on. I’m trying anything now 🙁
 
If the routes are not synced, have you tried sending a favorite location.

You say they are visible on your GPS, are they also visible on the Mydrive web page?
 
Hi @cragman7
Can confirm I am having the exact same issues.
Routes synched fine when setup on web, and they appeared in both the MyDrive app and the TomTom Go app on my iPhone.

Now routes only synch to the MyDrive app.

Saved places synch fine between all 3 so no issues regarding login details etc.

I have done the old reinstall of the app etc. but nothing seems to work.

Must admit it’s been a few weeks since I last tried syncing routes but all seemed fine then so something has happened since then to cause this issue, and given it’s happening to us both then I am presuming (Maybe wrongly) that it is at TomTom end.

Sorry I have made same post to both the active discussions around the same issue.
 
For the original poster with the Carpuride…don’t bother with the crappy Tom Tom app. Just use Apple CarPlay on the Carpuride. Plot your routes on the iPhone using a different app (I really like MyRouteApp.com).
 
For the original poster with the Carpuride…don’t bother with the crappy Tom Tom app. Just use Apple CarPlay on the Carpuride. Plot your routes on the iPhone using a different app (I really like MyRouteApp.com).
I have 160 routes in my drive. 12 written for a tour that starts at the weeken. if the routes would sync into the Go app, all would be good. It’s a bit late to try to learn how to route on MRA or use it on the tour 😕
 
If the routes are not synced, have you tried sending a favorite location.

You say they are visible on your GPS, are they also visible on the Mydrive web page?
All routes are on My drive, all routes are on the rider 550. All routes were in TomTom go and worked two weeks ago. Now they have gone from Go.
my places works fine, recent destinations all there.
 
I have the same issue. Spoke with support and they said that it was a known issue, fix date unknown. I cancelled my membership for now. I really WANT it to work... same reasons... I have a rider 550 that's begun to act up (after a software update I've noticed) and I have a crapload of routes. I too got a carpuride 7.... wonderful btw mounted above the dash.... I want go to work. I'll revisit later and see if it works.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Members online

Latest resources

Forum statistics

Threads
29,155
Messages
197,157
Members
68,213
Latest member
JMS

Latest Threads

Back
Top