my go510 doesn't turn on anymore

Discussion in 'General TomTom Discussion' started by DJboozeAlot, Aug 11, 2008.

  1. DJboozeAlot

    DJboozeAlot

    Joined:
    Feb 25, 2008
    Messages:
    2
    Likes Received:
    0
    i always use the car charger when using my tomtom go 510, i NEVER use it without it being plugged into the charger. well, funny thing is, the first and only time i used it without the charger, the battery died while on a trip and when i got home i plugged it into my car charger, and it won't turn on anymore! i left it to charge for over an hour during a road trip, and it won't turn on. when you press the power button, the green light comes on, and the green light comes on when you plug it into the charger as well, but that's it.

    i did a quick google search, and found that others have had this problem, and fixed it by hitting a reset button on the back of the unit. i found the reset button and pushed it for 15 seconds, but it still won't turn on.

    obviously it's not worth repairing due to the cost compared to it's age, so before i smash it with a baseball bat, anyone know of a possible simple fix, or something i can try?
     
    Last edited: Aug 11, 2008
    DJboozeAlot, Aug 11, 2008
    #1
    1. Advertisements

  2. DJboozeAlot

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    23,056
    Likes Received:
    446
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    Try a pin reset. If that doesn't work, call Support. They may have a suggestion.
     
    dhn, Aug 11, 2008
    #2
    1. Advertisements

  3. DJboozeAlot

    Pedro2NR

    Joined:
    Aug 30, 2006
    Messages:
    5,937
    Likes Received:
    139
    Location:
    Downey, California
    TomTom Model(s):
    GO 910, ONE V2, GO 920 GO 730 & iPad TT App
    the reset button on the 510 is actually on the bottom and not the back.
    follow the steps from the officia site
     
    Pedro2NR, Aug 11, 2008
    #3
  4. DJboozeAlot

    DJboozeAlot

    Joined:
    Feb 25, 2008
    Messages:
    2
    Likes Received:
    0
    i did try the reset button, but it did not help. i followed the instructions from the tomtom site
     
    DJboozeAlot, Aug 12, 2008
    #4
  5. DJboozeAlot

    Pedro2NR

    Joined:
    Aug 30, 2006
    Messages:
    5,937
    Likes Received:
    139
    Location:
    Downey, California
    TomTom Model(s):
    GO 910, ONE V2, GO 920 GO 730 & iPad TT App
    Contact TT Support and they will help you out.
     
    Pedro2NR, Aug 12, 2008
    #5
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.