My Drive Connect v 4.2.6 .3888 issue


Joined
Nov 16, 2019
Messages
6
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
Start 125 M
I have a TomTom Start 25 M which connects to MyDrive as soon as connected to the PC. The issue is it won't download the updates for it. Keep getting excuses that the servers are busy which they clearly are not. I have to keep uninstalling and reinstalling MyDrive for it to work. I use an uninstaller that clears the registry as well as removing the program. Tried all the usual auto suggestions but only re-installing works. Any ideas please as it's a pain to uninstall/reinstall all the time?
 
Ad

Advertisements

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,188
Location
Toronto Canada
TomTom Model(s)
1535 LIVE; Via 1605; Go 50; Go 520
Might you have an antivirus or firewall impeding proper transmission?
 
Joined
Nov 16, 2019
Messages
6
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
Start 125 M
Thank for your reply. The issue occurs over several laptops with varying security software unfortunately. I've ruled out that possibility. On my daughter's laptop there's a previous version of MyDrive which does not auto update and you can refuse to update it. Last time I tried it on that laptop it updated with no issues. Unfortunately the laptop isn't to hand at the moment to check which version of MyDrive it is. Just the fact of uninstalling and reinstalling it makes me think there's a bug in the program possibly?
 

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,188
Location
Toronto Canada
TomTom Model(s)
1535 LIVE; Via 1605; Go 50; Go 520
Support:

United Kingdom
02079 490 134
Monday - Friday: 9:00 a.m. to 5:30 p.m.
 

Arno

Moderator
Joined
Jun 3, 2008
Messages
3,720
Location
Toronto - Pickering, ON
Country
<img src="/styles/default/custom/flags/ca.png" alt="Canada" /> Canada
TomTom Model(s)
930; GO 620; Start 63
Unless your Uninstaller removed all previous versions, try install a previous one by going to
--- > AppData > Local > TomTom > HOME3 > Updates

Once that works, do what ever you wanted to do with MDC and then, if Update is offer at the top of the page, proceed. If not there open MDC by right clicking the tray icon, click Settings > Downloads and pick options there.
 
Ad

Advertisements

Joined
Nov 16, 2019
Messages
6
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
Start 125 M
Unless your Uninstaller removed all previous versions, try install a previous one by going to
--- > AppData > Local > TomTom > HOME3 > Updates

Once that works, do what ever you wanted to do with MDC and then, if Update is offer at the top of the page, proceed. If not there open MDC by right clicking the tray icon, click Settings > Downloads and pick options there.
Used Geek uninstaller and have no previous versions. I think I might know the culprit - have my suspicions anyway. Could be Ccleaner. Won't run it again until after the next round of updates and if MyDrive updates the TomTom okay then Ccleaner goes to the bin.
 
Joined
Nov 16, 2019
Messages
6
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
Start 125 M
Just some more info. Plugged in TT and this message -


Then this from Start 25
"To make a connection between your TomTom
navigation device and your computer, all you have to do
is go to tomtom.com/getstarted."

Trying to get to my account from the tab on My Drive results in the loading circle that turns forever. So it's not connecting to my account and yes I'm logged in.

This is what I did this time to get it to work. Logged out of My Drive with the TomTom disconnected. Exited My Drive from the notification area (quit). Started My Drive and logged in - connected the TomTom and the damned thing updated with no issue. Saves the uninstall/reinstall pain :)

Still doesn't connect to my account though. Using Windows firewall and Defender with ransomware protection off when trying to update. I think a My Drive issue rather than my system?
 

Arno

Moderator
Joined
Jun 3, 2008
Messages
3,720
Location
Toronto - Pickering, ON
Country
<img src="/styles/default/custom/flags/ca.png" alt="Canada" /> Canada
TomTom Model(s)
930; GO 620; Start 63
On danger of stating the obvious, are you using the same user name and password in MDC as with your Start 25?
 
Ad

Advertisements

Joined
Nov 16, 2019
Messages
6
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
Start 125 M
On danger of stating the obvious, are you using the same user name and password in MDC as with your Start 25?
Yes. Thanks for the reply. Odd that it can connect to update but not connect to account. Just logged in online okay.

 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top