iPhone 4 and Traffic subscription USA

Discussion in 'Mobile Navigation' started by davidalan99, Mar 22, 2011.

  1. davidalan99

    davidalan99

    Joined:
    Jan 26, 2007
    Messages:
    193
    Likes Received:
    10
    Location:
    Baltimore MD
    TomTom Model(s):
    740 Live (not Used), Iphone 4 with TomTom & Navigon and TomTom Car Kit (not used)
    Prior to upgrading to IOS 4.3 I had till May 2011 on my traffic subscription. Today the first time I used my iPhone 4 after setting the route and seeking traffic I get the following under Traffic, "No Active subscription". What happened to my traffic? I tried the restore Purchases button and still nothing
    Location USA
    iPhone 4 on IOS 4.3
    TomTom iPhone 4

    solved
    Ok it has been several days on the phone with TomTom and with iTunes: now the problem solved

    First iTunes is now trying to delete several charges on my account, TomTomUSA and Canada and 4 traffic subscritptions

    Just got off with one of the TomTom upstairs support guys. I am sorry but in my excitement I forgot his name. My traffic is back. he was simple great. a 10+ on a 10 scale

    The most important thing is every TomTom devise must have a unique email address. There was some cross over between my 740 and my iPhone. We have solved by using my old account on the iPhone not the new gmail address. And one shot and traffic is back. I am now valid until 2013. I do not really care it seems to be working.

    If you run into a problem before you go off the deep end confirm your email address for the devise with them.
     
    davidalan99, Mar 22, 2011
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.