I had a GO510 dwhich has battery problem Replaced by a DEAD 720

Discussion in 'Hardware and Peripherals' started by frmichaud, Mar 24, 2009.

  1. frmichaud

    frmichaud

    Joined:
    Feb 23, 2009
    Messages:
    15
    Likes Received:
    0
    Location:
    Longueuil / QC / Canada
    TomTom Model(s):
    GO 510
    After a lot of exchanges by email with TomTom , I obtained an RMA to return the Go510, 3 weeks later I receive a refurbished GO720 BUT IT IS DEAD
    Yes you read dead, impossible to have a sound comming out of it, impossible to test voices, and after an hour it still have not catch any satellite, I can navigate inside the menus but when I select something that make NO CHANGE
    What do I do now
    Thanks
    Francois
     
    frmichaud, Mar 24, 2009
    #1
    1. Advertisements

  2. frmichaud

    canderson Moderator

    Joined:
    Dec 28, 2007
    Messages:
    11,234
    Likes Received:
    206
    Location:
    Colorado, USA
    TomTom Model(s):
    GO720, GO740TM Live, GO 1535 Live, Via 1535, Via 1605, GO 52, GO 600, GO 620, GO 630, TomTom Bridge
    Same thing you did with regard to the 510, only this time, cross your toes, not just your fingers. :eek:

    You could try the famous "pin reset", but it's unlikely that it will resolve such a collection of problems as you seem to have. As a last ditch attempt before returning this one for yet another, you could see if TTHome will reload the firmware for you. It's either corrupt firmware or some really bad hardware they sent you. If you can't load firmware, or that doesn't help, they need to get you another unit.
     
    canderson, Mar 24, 2009
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.