Go Premium X borked


Joined
Oct 10, 2020
Messages
4
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
Go Premium X
My TomTom Go Premium X worked yesterday morning but switched itself off for my
journey home in the afternoon. It was connected to the supplied in car charger, which charged my phone

I have put it on a mains charger for 3 hours but it wouldn’t start up.

The TomTom Community page on the website says I’m banned!! And so I can’t
ask any questions or get help!

The Drive App says it can’t send a message to TomTom!!!!!!

The unit is 11 months old. I called the service number & a guy from india remotely tried on my PC to do something but failed. Because I can't turn on the unit.
Why am I banned on the forum? I don't think I've ever been on it.
I got a new phone with a different number - does TomTom think I stole the unit?
I have the old phone and number as well.
Sorry for the rant but I'm stuck
 
Ad

Advertisements

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,185
Location
Toronto Canada
TomTom Model(s)
1535 LIVE; Via 1605; Go 50; Go 520
Did you try this number? (It's chat only)

United Kingdom
02079 490 134
Monday - Friday: 9:00 a.m. to 5:30 p.m.
 

canderson

Moderator
Joined
Dec 28, 2007
Messages
11,386
Location
Colorado, USA
TomTom Model(s)
GO720, GO740TM Live, GO 1535 Live, Via 1535, Via 1605, GO 52, GO 600, GO 620, GO 630, TomTom Bridge
Rather than a brief press of the power button, have you tried a sustained press (20 seconds or so) to see if eventually the TomTom logo comes up?
 
Joined
Oct 10, 2020
Messages
4
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
Go Premium X
No, but it was closed by the time I made sure it wasn’t just out of charge.
But I’ll try them on Monday. Thanks
 
Joined
Oct 10, 2020
Messages
4
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
Go Premium X
Rather than a brief press of the power button, have you tried a sustained press (20 seconds or so) to see if eventually the TomTom logo comes up?
Yep and now my finger hurts but it still won’t turn on
 
Joined
Oct 10, 2020
Messages
4
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
Go Premium X
Update: I turned it on Monday morning & it started. The battery symbol was bounded in red (not charged?). Put it in the car & it was fine. And on the way home.
I give up
 
Ad

Advertisements

canderson

Moderator
Joined
Dec 28, 2007
Messages
11,386
Location
Colorado, USA
TomTom Model(s)
GO720, GO740TM Live, GO 1535 Live, Via 1535, Via 1605, GO 52, GO 600, GO 620, GO 630, TomTom Bridge
Normally, if the battery is knackered, you will get the big red battery symbol on the screen, and it will shut off right away. This can even happen when connected to power until such time as the battery gets a bit of charge on it.
So one wonders what the story is/was with charging the battery on this unit. Beginning to wonder about the connectors.
Keep us posted, please. It's a curious one.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top