Go 720 says 'no map found' after uploading USA and canada! why?


Joined
Feb 2, 2014
Messages
2
TomTom Model(s)
go 720
we have a Go720 which we purchased new from Halfords in Uk a few years ago with western Europe already uploaded. we have never updated etc until yesterday when we purchased 'USA and Canada' maps as we are spending a few months in USA now. we downloaded tomtom home and downloaded all the suggested updates . I understand that there is not room on the internal memory for both Europe and USA, so we agreed to save western Europe maps to my computer via HOME and upload the USA maps. (I originally tried to do this onto a 8 GB memory card but it wouldn't work, and I found a thread saying they would only work with 4GB or less, so we decided to go the internal memory route instead ). unfortunately after hours of uploading, the device now says 'no maps found' (even after resetting the device). The HOME programme is not helpful- 'operate my device' on the computer says 'no maps found', the 'manage my go' says that the USA and Canada map is loaded on my device! I am confused and frustrated, having already spent hours trying to sort this out!! Please help.
 
Ad

Advertisements

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,374
Location
Toronto Canada
TomTom Model(s)
Go 50; Go 520
Did you try Manage maps-->switch maps?

Also, try a pin reset on the bottom of the device.

But before doing any of that............................

Connect to Home and go to Update my Device. An application should be offered. (Don't select any other items, if offered Accept it and install. Disconnect PROPERLY from Home using the Device Disconnect icon.

Reconnect to Home. See if any further application updates are offered. If so, go through the install process till no further applications are offered. The latest for the 720 should be 9.510.

Now do the pin reset on the device and see if the device recognizes the map.

If so, make an Explorer, not Home backup before doing anything else.

See here:

https://www.tomtomforums.com/thread...-to-the-computer-and-how-to-restore-it.17864/
 

canderson

Moderator
Joined
Dec 28, 2007
Messages
12,088
Location
Colorado, USA
TomTom Model(s)
GO720, GO740, GO 1535, Via 1535, Via 1605, GO 52, GO 600, GO 620, GO 630, GO Discover, TomTom Bridge
Yes - one wonders if he's even yet up to 8.302 that would support the larger card.
 
Joined
Feb 2, 2014
Messages
2
TomTom Model(s)
go 720
thank you so much dhn , after a whole weekend of trying it has finally worked- yay!
 
Ad

Advertisements

canderson

Moderator
Joined
Dec 28, 2007
Messages
12,088
Location
Colorado, USA
TomTom Model(s)
GO720, GO740, GO 1535, Via 1535, Via 1605, GO 52, GO 600, GO 620, GO 630, GO Discover, TomTom Bridge
Did you find it necessary to move to more recent firmware to get the card to work?
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top