Go 6100 shutting down

Discussion in 'Technical Support' started by Sean b, Dec 4, 2019 at 5:39 PM.

  1. Sean b

    Sean b

    Joined:
    Wednesday
    Messages:
    2
    Likes Received:
    0
    TomTom Model(s):
    GO 6100
    Please bear with me as this is my first effort to use this forum.
    I don’t use my Tom Tom very often but recently when i plug the unit into my car and turn on it fires up ok but very quickly shuts down stating that the battery is empty.
    I removed the unit and charged it up at home for 24hrs, plugged it back in the car and all appeared well.
    However went to use the unit a week later and unit shut down again with the same battery problem.
    Looked on Tom Tom website for an answer to this problem but it stated that the unit should run ok even with a flat battery as long as it’s plugged into the usb power supply.
    Does the unit require a battery replacement, or is it faulty.
    Thanks Sean b
     
    Sean b, Dec 4, 2019 at 5:39 PM
    #1
    1. Advertisements

  2. Sean b

    dhn Moderator

    Joined:
    Oct 1, 2007
    Messages:
    23,016
    Likes Received:
    444
    Location:
    Toronto Canada
    TomTom Model(s):
    1535 LIVE; Via 1605; Go 50; Go 520
    The device really should be connected to a cig lighter outlet in the vehicle, not a usb port as the latter only provides .5 A power, not enough to run the device and charge the battery.
     
    dhn, Dec 4, 2019 at 7:54 PM
    #2
    1. Advertisements

  3. Sean b

    Sean b

    Joined:
    Wednesday
    Messages:
    2
    Likes Received:
    0
    TomTom Model(s):
    GO 6100
    Thanks for your rapid reply,will try cigarette socket option tomorrow
    Sean
     
    Sean b, Dec 5, 2019 at 9:12 AM
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.