Go 6100 shutting down


Joined
Dec 4, 2019
Messages
2
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
GO 6100
Please bear with me as this is my first effort to use this forum.
I don’t use my Tom Tom very often but recently when i plug the unit into my car and turn on it fires up ok but very quickly shuts down stating that the battery is empty.
I removed the unit and charged it up at home for 24hrs, plugged it back in the car and all appeared well.
However went to use the unit a week later and unit shut down again with the same battery problem.
Looked on Tom Tom website for an answer to this problem but it stated that the unit should run ok even with a flat battery as long as it’s plugged into the usb power supply.
Does the unit require a battery replacement, or is it faulty.
Thanks Sean b
 
Ad

Advertisements

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,156
Location
Toronto Canada
TomTom Model(s)
1535 LIVE; Via 1605; Go 50; Go 520
The device really should be connected to a cig lighter outlet in the vehicle, not a usb port as the latter only provides .5 A power, not enough to run the device and charge the battery.
 
Ad

Advertisements

Joined
Dec 4, 2019
Messages
2
Country
<img src="/styles/default/custom/flags/gb.png" alt="United Kingdom" /> United Kingdom
TomTom Model(s)
GO 6100
The device really should be connected to a cig lighter outlet in the vehicle, not a usb port as the latter only provides .5 A power, not enough to run the device and charge the battery.
Thanks for your rapid reply,will try cigarette socket option tomorrow
Sean
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top