Getting TomTom back to new


Joined
Sep 19, 2012
Messages
7
Location
UK
TomTom Model(s)
Via Live 120
Hi all,

I have a TomTom Via Live 120 that on startup shows a red cross. I have searched for a couple of days now and tried everything i found but nothing has worked.

I was given the TomTom so dont have anything backed up on my laptop so ideally like to keep all of the maps.

Any advice on how to get this thing back to new bearing in mind this thing wont turn on :confused:

Thanks

Ben
 
Ad

Advertisements

Could you confirm, have you done all the steps HERE and HERE? Since I don't have a Via model, I'm not even sure if these steps are pertinent . . .
 
I'm afraid those two sets of instructions are only of use for the older "NAV2" TomTom models (Software Version 9 and below)

Nipz, there is a procedure for "emergency recovery" of the new models like the VIA ones, I'll just write it up in the "articles" section and post a link in a minute.

EDIT: here you go... New style TomToms - Emergency Recovery Mode
 
Last edited:
Thanks Andy for assembling and posting those instructions for the newer model owners!
 
Brilliant :) Thanks Andy_P and alfie67! I will try the new instructions now and let you know how i get on.
 
Ad

Advertisements

Just spent 30 mins trying to get into recovery mode and it wont do it...

I turn it on. Hold the power button down for the 20-30 secs but dont see the black screen with white text (unless the white text is the tomtom logo?).

Feel stupid! lol
 
Are you holding it BEYOND the drum roll sound? I just tried it and it takes about another 10 seconds after the drums.
 
Are you holding it BEYOND the drum roll sound? I just tried it and it takes about another 10 seconds after the drums.

Yea i hold it beyond the drum roll :confused: i tried pressing it 1-2-3 on the tomtom logo screen too and i get about a second of that cog showing up but then goes back to the red cross :mad:
 
Are you holding it BEYOND the drum roll sound? I just tried it and it takes about another 10 seconds after the drums.

Yea i hold it beyond the drum roll :confused: i tried pressing it 1-2-3 on the tomtom logo screen too and i get about a second of that cog showing up but then goes back to the red cross :mad:
The TomTom logo screen will normally appear at the same time as the "drum beat" sound. As Andy_P said, you need to keep holding the power button down continuously for some time after that, until the screen full of text appears.

When the screen of text appears - and only when it appears - you should finally let go of the power button. You should then quickly press and release the power button three times in rapid succession.

If you follow Andy's instructions exactly in every detail, and you do not get the cogged wheel that he described, I am not sure if there is anything else that can be done.

With best wishes,
- Tom -
 
Ad

Advertisements

Hi et, thanks for your input too. I have held the button down until the tomtom no longer does anything and never see this screen you both talk about :(

I will try and film what im doing tomorrow to show you.

Again thanks very much for your help.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Back
Top