Finally GO sound improved


Joined
Apr 14, 2016
Messages
5
Country
<img src="/styles/default/custom/flags/us.png" alt="United States" /> United States
TomTom Model(s)
XXL, Start, GO ....
I didn't know about the sound level problem with GO devices until I have tried myself. I was about to return my latest GO 50S when I got a prompt to install "require" update that was about 350mb is size and noted something about fixing sound.

After an update, I can now hear the freaking directional voice. it's still not as loud as Start nor the XXL i have but at 100% it's loud enough to hear with window down. for those contemplating on returning your GO device, update your software using your MyDrive Connect and hear the difference before returning.

One thing missing in GO is that I can't no longer create my own start/shutdown images and "pointer" icon. I have always used my actual vehicle to customize the device. May be next software update? I also wish there is a way to reorganize the options to fit my needs because I have to shuffle to cancel current destination. I have GO 50S but after the support reset "something" because I had an issue with updating the map, it now show as GO 50 in MyDrive Connect but the operators see 50S in their screens. I have given up fixing the traffic option that suppose to come with 50S which is not available at the moment and two operators have given up already. Traffic is not a show stopper so I have decided to keep it as it is.

My latest GO is so much more improved. Tracking is so much faster with very little lag time and recalculation is also faster. I am also glad GO device restored the auto on/off like the "old" XL I had long ago. screen transition and motions are also smoother.
 
Ad

Advertisements

canderson

Moderator
Joined
Dec 28, 2007
Messages
11,458
Location
Colorado, USA
TomTom Model(s)
GO720, GO740TM Live, GO 1535 Live, Via 1535, Via 1605, GO 52, GO 600, GO 620, GO 630, TomTom Bridge
Yup. Took them WAY too long to respond to the volume issue. The owners of the 400 model still don't have a fix. All the others seem to be resolved now.

If you do decide you'd like help with traffic, let us know.
 

Arno

Moderator
Joined
Jun 3, 2008
Messages
3,784
Location
Toronto - Pickering, ON
Country
<img src="/styles/default/custom/flags/ca.png" alt="Canada" /> Canada
TomTom Model(s)
930; GO 620; Start 63
I also wish there is a way to reorganize the options to fit my needs because I have to shuffle to cancel current destination.
I presume you GO 50 and my GO 600 use the same OS. If so, keep your finger on a button in the Main Menu. It will switch to reverse video with left/right arrows at the bottom of it. Use these to move the button where it suits you better.
 
Joined
Apr 14, 2016
Messages
5
Country
<img src="/styles/default/custom/flags/us.png" alt="United States" /> United States
TomTom Model(s)
XXL, Start, GO ....
I presume you GO 50 and my GO 600 use the same OS. If so, keep your finger on a button in the Main Menu. It will switch to reverse video with left/right arrows at the bottom of it. Use these to move the button where it suits you better.
i will definitely try that during lunch. thanks.
 
Joined
Apr 14, 2016
Messages
5
Country
<img src="/styles/default/custom/flags/us.png" alt="United States" /> United States
TomTom Model(s)
XXL, Start, GO ....
If you do decide you'd like help with traffic, let us know.
I am sure TomTom lost lot of money when everyone returned the devices. it was physically useless in previous mode.

so with traffic, this is what I have done so far; I have "reset" factor setting twice per supports I had worked with. MyDrive still shows GO 50 but support claim they see GO 50S and it isn't important what I see. Problem with that is once they reset "something", icon for life time traffic disappeared from 'my service' pane. I have tried three different phone to synch/connect to the GO device and also have failed. closest i got one time was the GO device registered "Blackberry" when all three phones I have attempted were Samsung S3, S5, and iphone6. Your recommendation is greatly appreciated. thanks.
 

dhn

Moderator
Joined
Oct 1, 2007
Messages
23,216
Location
Toronto Canada
TomTom Model(s)
Go 50; Go 520
Call support to assist then:

United States
866 486 6866
Monday - Friday: 9:00 a.m. to 8:00 p.m. EST
Saturday: 10:00 a.m. to 6:00 p.m EST
 
Ad

Advertisements

canderson

Moderator
Joined
Dec 28, 2007
Messages
11,458
Location
Colorado, USA
TomTom Model(s)
GO720, GO740TM Live, GO 1535 Live, Via 1535, Via 1605, GO 52, GO 600, GO 620, GO 630, TomTom Bridge
Bluetooth connection:

Let's start with the 'obvious'. That Blackberry that your GO found evidently belonged to someone else within Class I Bluetooth range. What you see on the GO screen is what is reported by the remote device, not the GO itself. Something was calling itself a Blackberry.

On your own phones, are they set up to be 'discovered'? Unless configured to do so, they aren't going to show up when the GO goes looking for Bluetooth devices.
 
Ad

Advertisements

Joined
Sep 9, 2008
Messages
273
Location
Philadelphia, PA
TomTom Model(s)
TomTom Go 620
Also, try a full shutdown. My GO 600's MyDrive icon disappeared too after I use it and sleep only for 2 weeks. After a full shutdown and restart, along with a drum restart, the function returns
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top